poiapp-api-key: switch to allarch class 37/21737/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 25 Jun 2019 23:09:57 +0000 (19:09 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 25 Jun 2019 23:22:49 +0000 (19:22 -0400)
Switch from setting PACKAGE_ARCH to inheriting the allarch class in the
poiapp-api-key recipe.  This fixes a failure when building an image with
the agl-demo-preload feature that seems due to a change between rocko
and thud.

Bug-AGL: SPEC-2567

Change-Id: I0ad6289897261ece5971cdea4888c6cd13793643
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb [changed mode: 0755->0644]

old mode 100755 (executable)
new mode 100644 (file)
index 4d53fdb..d353d7d
@@ -5,6 +5,8 @@ SECTION = "apps"
 LICENSE = "Proprietary"
 LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
 
+inherit allarch
+
 do_fetch[noexec] = "1"
 do_unpack[noexec] = "1"
 do_compile[noexec] = "1"
@@ -17,5 +19,3 @@ do_install () {
     echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
     echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
 }
-
-PACKAGE_ARCH = "all"