html5-dashboard: create recipe and add to html5 demo 55/23955/1 9.0.0 icefish/9.0.0 icefish_9.0.0
authorLorenzo Tilve <ltilve@igalia.com>
Thu, 6 Feb 2020 18:03:29 +0000 (19:03 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 14 Feb 2020 15:18:38 +0000 (15:18 +0000)
Bug-AGL: SPEC-3151

Change-Id: Iee5fcba63de56f7d326a9015902f63e4d48632bf
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
(cherry picked from commit 2e014bfbd0757f2e35559543ba78d95cbc88b2c5)

recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
new file mode 100644 (file)
index 0000000..534bd2d
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 dashboard Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}
index a963722..6ec717b 100644 (file)
@@ -24,6 +24,7 @@ AGL_APPS = " \
     html5-settings \
     html5-mixer \
     html5-mediaplayer \
+    html5-dashboard \
     "
 
 RDEPENDS_${PN}_append = " \