html5-mediaplayer: create recipe and add to html5 demo 51/23951/3
authorLorenzo Tilve <ltilve@igalia.com>
Thu, 6 Feb 2020 18:01:54 +0000 (19:01 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 14 Feb 2020 15:17:42 +0000 (15:17 +0000)
Bug-AGL: SPEC-3152

Change-Id: I70ada4d6cf6da76b03bca7c2d8905f364b8a460f
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
(cherry picked from commit 5000d2e090cc2c8df74a7a96804882e8e74d9bdf)

recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
new file mode 100644 (file)
index 0000000..2b14376
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 Mediaplayer Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}
index 7feb122..a963722 100644 (file)
@@ -23,6 +23,7 @@ AGL_APPS = " \
     html5-hvac \
     html5-settings \
     html5-mixer \
+    html5-mediaplayer \
     "
 
 RDEPENDS_${PN}_append = " \