html5-homescreen: create recipe and add to html5 demo 68/23768/2
authorLorenzo Tilve <ltilve@igalia.com>
Mon, 3 Feb 2020 15:05:25 +0000 (16:05 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 14 Feb 2020 12:49:31 +0000 (12:49 +0000)
Bug-AGL: SPEC-2401

Change-Id: I6bcc182f856fa56d76152e28a0ee96d74ff7b555
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
new file mode 100644 (file)
index 0000000..6895626
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 Homescreen Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-homescreen/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}
index 3a12c56..7feb122 100644 (file)
@@ -18,6 +18,7 @@ RDEPENDS_${PN} += "\
     "
 
 AGL_APPS = " \
+    html5-homescreen \
     html5-launcher \
     html5-hvac \
     html5-settings \