recipes-demo-hmi: add messaging recipe 41/21841/1
authorMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 9 Jul 2019 21:23:41 +0000 (00:23 +0300)
committerMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 9 Jul 2019 21:47:29 +0000 (00:47 +0300)
Add recipe to enable building of the new messaging
application.

Bug-AGL: SPEC-2566
Change-Id: I99dd95540a7324d21e3fec177fb7e1e076799811
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-demo-hmi/messaging/messaging_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/messaging/messaging_git.bb b/recipes-demo-hmi/messaging/messaging_git.bb
new file mode 100644 (file)
index 0000000..5812cea
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY     = "Messaging application for AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating messaging on AGL Distribution"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/messaging"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+            libqtappfw \
+            libhomescreen \
+            qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += "agl-service-bluetooth-map"