recipes-demo-hmi: add messaging recipe
[AGL/meta-agl-demo.git] / recipes-demo-hmi / messaging / messaging_git.bb
1 SUMMARY     = "Messaging application for AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating messaging on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/messaging"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV  = "${AGL_APP_REVISION}"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "qtquickcontrols2 \
17             libqtappfw \
18             libhomescreen \
19             qlibwindowmanager \
20 "
21
22 inherit qmake5 aglwgt
23
24 RDEPENDS_${PN} += "agl-service-bluetooth-map"