Integration Low CAN demo and High Lvl ViWi. 07/10107/10
authorRomain Forlot <romain.forlot@iot.bzh>
Mon, 10 Jul 2017 15:13:23 +0000 (15:13 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 30 Aug 2017 16:31:37 +0000 (16:31 +0000)
This integration use non automatic post installation at first
boot on a board.

Change-Id: I0f080c72ec98b9280256de20a45aa847714bebf0
Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb [new file with mode: 0644]
recipes-demo-hmi/low-can-demo/low-can-demo_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb b/recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb
new file mode 100644 (file)
index 0000000..4391883
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY     = "High level ViWi service"
+DESCRIPTION = "AGL High Level service using ViWi protocol to expose CAN API."
+HOMEPAGE    = "https://github.com/iotbzh/high-level-viwi-service"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5de84541278ea4e62cacfdc0f890c459"
+
+SRC_URI = "gitsm://github.com/iotbzh/high-level-viwi-service.git;protocol=https"
+SRCREV  = "c4935e58769966a9b79b21c45798ab8828fe0ad0"
+
+PV = "4.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += "low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"
diff --git a/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
new file mode 100644 (file)
index 0000000..6b8f6b5
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY     = "Low CAN demo HTTP5 UI"
+DESCRIPTION = "AGL HTTP5 UI to display car metric (speed, rpm, ...) on AGL Distribution"
+HOMEPAGE    = "https://github.com/iotbzh/low-can-demo"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "gitsm://github.com/iotbzh/low-can-demo.git;protocol=https"
+SRCREV  = "df5cf4027d1978bd3ac37d583e711f134dd4a406"
+
+PV = "4.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += " low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"
index c41c896..2cf2b6e 100755 (executable)
@@ -51,6 +51,8 @@ AGL_APPS = " \
     poiapp \
     radio \
     settings \
+    high-level-viwi-service \
+    low-can-demo \
     "
 
 RDEPENDS_${PN}_append = " \