agl-demo-platform: add packagegroup smartdevicelink 37/10637/2
authorPhong Tran <tranmanphong@gmail.com>
Sun, 13 Aug 2017 20:17:26 +0000 (22:17 +0200)
committerPhong Tran <tranmanphong@gmail.com>
Sun, 13 Aug 2017 20:35:17 +0000 (22:35 +0200)
Add the new packagegroup name packagegroup-agl-smartdevicelink.
This install to agl-demo-platform image with "agl-sdl" in DISTRO_FEATURES

Tested build ok with:
source meta-agl/scripts/aglsetup.sh -m raspberrypi3 agl-demo agl-netboot agl-appfw-smack agl-sdl

Change-Id: I1b348affa88f0f3c1a313b2856bd38482fd8e778
Depends-On: I416d8418c0ef4fe4de5e5ce084e7b9075e64f85f
Signed-off-by: Phong Tran <tranmanphong@gmail.com>
recipes-platform/packagegroups/packagegroup-agl-demo.bb
recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb [new file with mode: 0644]
templates/feature/agl-sdl/50_bblayers.conf.inc [new file with mode: 0644]
templates/feature/agl-sdl/50_local.conf.inc [new file with mode: 0644]

index 3a7370a..9182491 100644 (file)
@@ -11,11 +11,14 @@ PACKAGES = "\
 
 ALLOW_EMPTY_${PN} = "1"
 
+SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
+    'packagegroup-agl-smartdevicelink', '', d)}"
 
 RDEPENDS_${PN} += "\
     packagegroup-agl-appfw \
     homescreen \
     udisks \
+    ${SMARTDEVICELINK} \
     "
 
 # fonts
diff --git a/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
new file mode 100644 (file)
index 0000000..108e9b7
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Set of packages for SmartDeviceLink"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-smartdevicelink \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    sdl-core \
+    "
diff --git a/templates/feature/agl-sdl/50_bblayers.conf.inc b/templates/feature/agl-sdl/50_bblayers.conf.inc
new file mode 100644 (file)
index 0000000..ffd8fab
--- /dev/null
@@ -0,0 +1,3 @@
+BBLAYERS =+ "${METADIR}/meta-sdl \
+       ${METADIR}/meta-openembedded/meta-gnome \
+       "
diff --git a/templates/feature/agl-sdl/50_local.conf.inc b/templates/feature/agl-sdl/50_local.conf.inc
new file mode 100644 (file)
index 0000000..10b8188
--- /dev/null
@@ -0,0 +1 @@
+DISTRO_FEATURES_append = " agl-sdl"