Hotfix : Correct navigation dependency 09/10509/1
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Fri, 28 Jul 2017 14:28:42 +0000 (23:28 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 4 Aug 2017 17:29:24 +0000 (17:29 +0000)
Currently, the dependency of navigation is broken. libdbusC++ is not installed.
We will implement provisional response for DD.

Change-Id: If29fffdd2279ccbe852632b3495cf9a951e46874
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/navigation/navigation_git.bb
recipes-demo-hmi/navigation/poiapp_git.bb [changed mode: 0755->0644]

index 70afe97..bc62ef4 100644 (file)
@@ -12,7 +12,8 @@ DEPENDS = " \
           wayland libdbus-c++ af-main \
           "
 
-RDEPENDS_${PN} = " flite openjtalk "
+RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
+                   wayland libdbus-c++ af-main "
 
 SRCREV="c6403c1147fa53cd6a638f738d270c5d3bb214cf"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
old mode 100755 (executable)
new mode 100644 (file)
index 7e60807..4938984
@@ -12,6 +12,9 @@ inherit aglwgt
 DEPENDS += " qtbase libdbus-c++ json-c \
            "
 
+RDEPENDS_${PN} =  " qtbase libdbus-c++ json-c \
+                  "
+
 SRCREV  = "b0e059007de776450c91c983a2bcac20414617e9"
 SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
           "