Temporarily fix the navigation app until SPEC-384 and SPEC-785 are fixed 15/10415/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 26 Jul 2017 20:02:49 +0000 (22:02 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 27 Jul 2017 14:43:59 +0000 (14:43 +0000)
The navigation app is not fully converted to a wgt
as it expects to ship a platform library instead
of containing all parts in the wgt.

For now (due to the short time until the dab release)
mitigate the issue by allowing the platform install.

Change-Id: Ic9430c56cf459be2c466e186320bc97cdc8d628d
Bug-AGL: SPEC-384 SPEC-785
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/navigation/navigation_git.bb

index 6c8195a..70afe97 100644 (file)
@@ -37,6 +37,14 @@ do_compile_prepend() {
 }
 
 do_install_append() {
+   # Attention: BUG: app ships native lib as part of platform
+   # see SPEC-785 and SPEC-384
+   # /start FIXME __________________
+     cd ${B}
+     oe_runmake 'DESTDIR=${D}' install
+     rm ${D}/usr/bin/navi
+   # /end   FIXME ^^^^^^^^^^^^^^^^^^^
+
    install -d ${D}/usr/AGL/apps
    mkdir -p ${B}/package/
    mv ${B}/navigation.wgt ${B}/package/