navigation: Switch to pipewire output 88/21988/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 25 Jul 2019 18:43:27 +0000 (14:43 -0400)
committerScott Murray <scott.murray@konsulko.com>
Thu, 25 Jul 2019 18:43:27 +0000 (14:43 -0400)
Update patch for the navigation app's talk scripts to use the gstreamer
pipewire output sink, and set the media role stream property
appropriately.

Bug-AGL: SPEC-2634

Change-Id: Ibb1e588688be8af9eff9c8e3efa1ca4983920df7
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/navigation/0001-switch-to-pipewire-output.patch [moved from recipes-demo-hmi/navigation/navigation/0001-switch-to-alsa-output.patch with 64% similarity]
recipes-demo-hmi/navigation/navigation_git.bb

@@ -1,16 +1,15 @@
-gpsnavi: Switch to ALSA output
+gpsnavi: Switch to pipewire output
 
-Update the talk scripts to use ALSA output via gst-launch-1.0 instead
-of PulseAudio's paplay.  gstreamer is used since it is likely that a
-further revision will change to a pipewire output sink and add back
-setting a role property.
+Update the talk scripts to use pipewire output via gst-launch-1.0
+instead of PulseAudio's paplay.  gstreamer is used to allow using the
+pipewire output sink and set its media role property.
 
 Upstream-Status: Inappropriate [no upstream]
 
 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
 
 diff --git a/flite_agl.in b/flite_agl.in
-index 28b512c..67a09e5 100644
+index 28b512c..be41d66 100644
 --- a/flite_agl.in
 +++ b/flite_agl.in
 @@ -1,6 +1,6 @@
@@ -18,11 +17,11 @@ index 28b512c..67a09e5 100644
  TMP=/tmp/navi.wav
  echo "$1" | flite_hts_engine -m  @datadir@/Voice/us/cmu_us_arctic_slt.htsvoice -o $TMP
 -paplay --property='media.role=Navi' $TMP
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! alsasink
++gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! pwaudiosink stream-properties="p,media.role=Navigation"
  rm -f $TMP
  
 diff --git a/jtalk_agl.in b/jtalk_agl.in
-index 76900f4..73c87e5 100644
+index 76900f4..0ca6975 100644
 --- a/jtalk_agl.in
 +++ b/jtalk_agl.in
 @@ -1,6 +1,6 @@
@@ -30,6 +29,6 @@ index 76900f4..73c87e5 100644
  TMP=/tmp/navi.wav
  echo "$1" | open_jtalk -ow $TMP -m @exec_prefix@/share/Voice/mei/mei_normal.htsvoice -x @exec_prefix@/share/dic/
 -paplay --property='media.role=Navi' $TMP
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! alsasink
++gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! pwaudiosink stream-properties="p,media.role=Navigation"
  rm -f $TMP
  
index 0a5f757..fefc058 100644 (file)
@@ -19,7 +19,7 @@ RDEPENDS_${PN} += " agl-service-navigation "
 
 SRCREV="89dc0052aced411ef09f8e0034fb5cf2c96ee637"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
-         file://0001-switch-to-alsa-output.patch \
+         file://0001-switch-to-pipewire-output.patch \
          file://0002-openssl-1.1-fixes.patch \
          file://0003-update-permissions.patch \
          file://download_mapdata_jp.sh \