ondemandnavi: Update recipe SRC_URI and HOMEPAGE 57/21957/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 25 Jul 2019 12:31:54 +0000 (08:31 -0400)
committerScott Murray <scott.murray@konsulko.com>
Thu, 25 Jul 2019 13:03:28 +0000 (13:03 +0000)
Update recipe SRC_URI and HOMEPAGE to point at the new repository on
AGL Gerrit, and remove the local patches that have now been merged
there.  As well, the recipe has been reformatted to more closely match
the OpenEmbedded style guide and match those of the other demo
applications.

Bug-AGL: SPEC-2667

Change-Id: Ie771a2ea8e6236a5995dbb9c2b9d64cfbe30e89c
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/ondemandnavi_git.bb

index 6cc2681..03c3cdb 100644 (file)
@@ -1,41 +1,40 @@
 SUMMARY     = "AGL Reference On Demand Navigation application."
-DESCRIPTION = "This application provides the function of Navigation to AGL. "
-HOMEPAGE    = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0"
+LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-inherit qmake5 aglwgt pkgconfig
+DEPENDS += "qtquickcontrols2 \
+            qlibhomescreen \
+            qlibwindowmanager \
+            qtlocation \
+            qtaglextras \
+"
 
-SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
-           file://0001-switch-to-alsa-output.patch \
-           file://0002-update-permissions.patch \
-           file://org.agl.naviapi.conf \
-           "
-SRCREV  = "a6930c2dff988e45e18f91a2368d829c08942b30"
-
-DEPENDS += " qtbase qtquickcontrols2 \
-             qlibhomescreen \
-             qlibwindowmanager \
-             qtlocation qtaglextras \
-           "
-
-RDEPENDS_${PN} += " qtlocation \
-                    flite \
-                    openjtalk \
-                    gstreamer1.0 \
-                    ondemandnavi-config \
-                  "
+PV = "1.0+git${SRCPV}"
 
-RPROVIDES_${PN} = "virtual/navigation"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
+           file://org.agl.naviapi.conf \
+"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
+inherit qmake5 aglwgt pkgconfig
+
 do_install_append() {
    install -d ${D}/etc/dbus-1/session.d/
    install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
 }
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+RDEPENDS_${PN} += "qtlocation \
+                   flite \
+                   openjtalk \
+                   gstreamer1.0 \
+                   ondemandnavi-config \
+"
+
+RPROVIDES_${PN} = "virtual/navigation"