Fix building agl-kvm-demo-platform for h3ulcb-kf 56/28656/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 18 Apr 2023 22:20:12 +0000 (18:20 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 18 Apr 2023 22:27:34 +0000 (18:27 -0400)
Changes:
- Add masking the meta-rcar-gen3-adas layer to the KVM guest
  multiconfig to avoid picking up the dangling bbappends in
  meta-agl-bsp when building the guests.
- Remove the MACHINE_SUFFIX logic from the guest image copying in
  the agl-kvm-demo-platform recipe; it is a leftover from the
  original logic used in the IC EG container host images, and is
  unneeded here since the host and guests will be different
  MACHINEs (and the guest realistically cannot use the -kf
  machines).

Bug-AGL: SPEC-4760

Change-Id: If3237ca4d9fc86fc9d289a95bda24a4afcc7a991
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
conf/multiconfig/agl-kvm-guest.conf
recipes-platform/images/agl-kvm-demo-platform.bb

index b13630d..478bc5f 100644 (file)
@@ -4,7 +4,7 @@ MACHINE = "virtio-aarch64"
 
 # Avoid parse errors caused by linux-renesas, and all the other
 # random bbappends in meta-rcar-gen3.
-BBMASK += "meta-rcar-gen3/ meta-agl-refhw-gen3/"
+BBMASK += "meta-rcar-gen3/ meta-rcar-gen3-adas/ meta-agl-refhw-gen3/"
 
 DISTRO_FEATURES:append = " kvm virtualization"
 
index d04186b..378ea83 100644 (file)
@@ -36,9 +36,6 @@ GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAG
 
 QEMU_GUEST_CONFIGS ?= ""
 
-# Handle modification of IMAGE_LINK_NAME done by ULCB builds with Kingfisher support
-MACHINE_SUFFIX = "${@bb.utils.contains('AGL_FEATURES', 'kingfisher', '-kf', '', d)}"
-
 python __anonymous() {
     for c in (d.getVar('GUEST_IMAGES') or "").split():
         (mc, image) = c.split(':')
@@ -56,7 +53,7 @@ install_guest_images() {
         name=${image}
         rm -rf  ${IMAGE_ROOTFS}/var/lib/machines/${name}
         install -m 0755 -d ${IMAGE_ROOTFS}/var/lib/machines/${name}
-        src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}${MACHINE_SUFFIX}.ext4"
+        src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}.ext4"
         bbnote "Installing ${src}"
         install -m 0600 ${src} ${IMAGE_ROOTFS}/var/lib/machines/${name}/
        # Placeholder until booting from kernel in VM image is worked out