Remove virtual/webruntime RPROVIDES 77/29677/2 17.90.0 ricefish/17.90.0 ricefish_17.90.0
authorScott Murray <scott.murray@konsulko.com>
Tue, 13 Feb 2024 22:13:17 +0000 (17:13 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 15 Feb 2024 15:10:08 +0000 (15:10 +0000)
At this point it is not really the case that WAM can be switched
out for another web runtime, so just remove the virtual/webruntime
RPROVIDES rather than rework it.

Bug-AGL: SPEC-5067

Change-Id: I0b55f483352c93e50e36d25d6237abe3598552b4
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29677
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
recipes-wam/wam/wam_git.bb

index 7ea23e7..9c93b32 100644 (file)
@@ -31,7 +31,7 @@ AGL_APPS = " \
     "
 
 RDEPENDS:${PN}:append = " \
-    virtual/webruntime \
+    wam \
     weston-ini-conf-landscape-no-activate \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
     qtquickcontrols2-agl \
index f80433c..f76641e 100644 (file)
@@ -53,6 +53,3 @@ FILES:${PN} += "${sysconfdir}/init \
                 ${libdir}/webappmanager/plugins/*.so"
 
 RDEPENDS:${PN} += " bash grpc-web-proxy"
-
-PROVIDES += "virtual/webruntime"
-RPROVIDES:${PN} += "virtual/webruntime"