qtwayland-config: remove recipe 56/29656/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 13 Feb 2024 22:10:40 +0000 (17:10 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 15 Feb 2024 15:10:08 +0000 (15:10 +0000)
Remove qtwayland-config recipe since nothing uses it, rather
than rework its RPROVIDES.

Bug-AGL: SPEC-5067

Change-Id: Ie6ac95319068f1bed560eb322f2625561bd6db82
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29656
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

recipes-qt/qt/qtwayland-config/qtwayland [deleted file]
recipes-qt/qt/qtwayland-config_1.0.0.bb [deleted file]

diff --git a/recipes-qt/qt/qtwayland-config/qtwayland b/recipes-qt/qt/qtwayland-config/qtwayland
deleted file mode 100644 (file)
index a371c6c..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-QT_WAYLAND_SHELL_INTEGRATION=@QT_WAYLAND_DEFAULT_SHELL@
-# The following might be necessary when multiple/split surfaces are created.
-# Without this, QtWayland will sometimes maintain the same/old size even if the
-# split surface is destroyed.
-# We keep it disabled by default as it causes an additional repaint of the
-# surface until the compositor sends a configure event to scale the window to
-# the actual area. Typical windows will, by default, have an initial size set
-# by qtwayland when starting-up (without an explicit size specified by the
-# application).
-# Note that QtWayland will only test the presence of the environment variable
-# so it will be enabled even if set to 0
-# QT_WAYLAND_RESIZE_AFTER_SWAP=1
diff --git a/recipes-qt/qt/qtwayland-config_1.0.0.bb b/recipes-qt/qt/qtwayland-config_1.0.0.bb
deleted file mode 100644 (file)
index 7c1e99b..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY     = "QtWayland config file."
-DESCRIPTION = "Config file for qtwayland."
-SECTION     = "apps"
-LICENSE     = "MIT"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRC_URI = "file://qtwayland"
-
-inherit allarch
-
-QTWAYLAND_DEFAULT_SHELL ?= "xdg-shell"
-
-do_compile[noexec] = "1"
-
-do_install () {
-    install -D -m 644 ${WORKDIR}/qtwayland ${D}${sysconfdir}/afm/unit.env.d/qtwayland
-    sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
-}
-
-RPROVIDES:${PN} += "virtual/qtwayland-config"