meta-agl-demo: remove Mocca application 69/14269/1
authorChristian Gromm <christian.gromm@microchip.com>
Fri, 8 Jun 2018 13:27:40 +0000 (15:27 +0200)
committerChristian Gromm <christian.gromm@microchip.com>
Fri, 8 Jun 2018 13:27:40 +0000 (15:27 +0200)
This patch removes the Mocca box application and the related
USB driver from the demo platform. It is needed to clean up
as the Mocca box is not used anymore.

Change-Id: Iebba72e773476b18974f7fff343f4e7b998090d9
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
recipes-kernel/mocca-usb/mocca-usb.bb [deleted file]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-kernel/mocca-usb/mocca-usb.bb b/recipes-kernel/mocca-usb/mocca-usb.bb
deleted file mode 100644 (file)
index cf4e585..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "Build USB driver for MOCCA box"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=${AGL_BRANCH}"
-S = "${WORKDIR}/git/Usb-Driver"
-SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
-    fi
-}
index 4ab64d0..c077287 100755 (executable)
@@ -22,7 +22,6 @@ RDEPENDS_${PN} += "\
 
 MOST_DRIVERS = " "
 MOST_DRIVERS_append_BROKENonIntelQemuRpi3 = " \
-    mocca-usb \
     most \
     "
 # Don't add MOST support when building for Porter
@@ -36,11 +35,6 @@ MOST_HVAC_append = " \
     agl-service-unicens \
     "
 
-# can-lin is a binary and only for porter :(
-MOST_HVAC_append_porter = " \
-    can-lin \
-    "
-
 # mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
 MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"