cf4e5856b5ab62042d07d03bf0fae52475068060
[AGL/meta-agl-demo.git] / recipes-kernel / mocca-usb / mocca-usb.bb
1 DESCRIPTION = "Build USB driver for MOCCA box"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=${AGL_BRANCH}"
10 S = "${WORKDIR}/git/Usb-Driver"
11 SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
12
13 # The inherit of module.bbclass will automatically name module packages with
14 # "kernel-module-" prefix as required by the oe-core build environment.
15
16 do_install_append () {
17     # modprobe automatically at boot
18     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
19         install -d ${D}${sysconfdir}/modules-load.d
20         echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
21     fi
22 }