Add AGL Demo Suide for ALS 2016 75/5975/5
authorTadao Tnikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 24 Jun 2016 02:11:43 +0000 (11:11 +0900)
committerWalt Miner <wminer@linuxfoundation.org>
Tue, 5 Jul 2016 13:40:24 +0000 (13:40 +0000)
Add AGL Demo Apps for ALS 2016 to be integrated into agl-demo-platform.

Change-Id: Iec3706c889c47de40fdee6944bee45d2ce3ebf09
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb [new file with mode: 0644]
recipes-platform/images/agl-demo-platform.bb

diff --git a/recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb b/recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb
new file mode 100644 (file)
index 0000000..04d00da
--- /dev/null
@@ -0,0 +1,36 @@
+SUMMARY     = "Homescreen for the AGL Demonstrator @ ALS2016"
+DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ ALS2016"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/ALS2016"
+
+SECTION     = "apps"
+
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI     = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/ALS2016;protocol=http"
+SRCREV      = "${AUTOREV}"
+
+PV = "1.0+git"
+
+RDEPENDS_${PN} += " \
+    qtmultimedia-qmlplugins \
+    qtquickcontrols-qmlplugins \
+    qtsvg-plugins \
+    "
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    ls
+}
+
+# plain copy in own folder for now
+do_install() {
+    mkdir -p ${D}/opt/AGL/ALS2016/
+    cp -ar ./* ${D}/opt/AGL/ALS2016/
+}
+
+FILES_${PN} = "/opt/AGL/"
index 2089e7a..4ae985e 100644 (file)
@@ -17,6 +17,7 @@ IMAGE_INSTALL_append = " \
 
 # add packages for CES2016 demo
 IMAGE_INSTALL_append = " \
+    ALS2016-demo \
     CES2016-demo \
     can-utils iproute2 \
     python-curses \