Add vss-tools and required dependencies 87/28887/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 12 May 2023 19:09:57 +0000 (15:09 -0400)
committerScott Murray <scott.murray@konsulko.com>
Mon, 15 May 2023 18:44:12 +0000 (18:44 +0000)
Add a vss-tools recipe to build the VSS specification tools,
and recipes for the python3-anytree, python3-deprecation, and
python3-graphql-core modules it requires.  The latter will be
submitted for meta-python.

Bug-AGL: SPEC-4761

Change-Id: Iffe665c0c6f168f3c37b35ce0346cad210d880c5
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-connectivity/vss/vss-tools_3.1.bb [new file with mode: 0644]
recipes-devtools/python/python3-anytree_2.8.0.bb [new file with mode: 0644]
recipes-devtools/python/python3-deprecation_2.1.0.bb [new file with mode: 0644]
recipes-devtools/python/python3-graphql-core_3.2.3.bb [new file with mode: 0644]

diff --git a/recipes-connectivity/vss/vss-tools_3.1.bb b/recipes-connectivity/vss/vss-tools_3.1.bb
new file mode 100644 (file)
index 0000000..b681d8d
--- /dev/null
@@ -0,0 +1,28 @@
+SUMMARY = "COVESA Vehicle Signal Specification tooling."
+HOMEPAGE = "https://github.com/COVESA/vss-tools"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=master"
+SRCREV = "97148190d0f84bedfc933b8bc4391c0a7e7a099b"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-core \
+    python3-ctypes \
+    python3-email \
+    python3-json \
+    python3-logging \
+    python3-netclient \
+    python3-pkg-resources \
+    python3-anytree \
+    python3-deprecation \
+    python3-graphql-core \
+    python3-pyyaml \
+    python3-six \
+"
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-anytree_2.8.0.bb b/recipes-devtools/python/python3-anytree_2.8.0.bb
new file mode 100644 (file)
index 0000000..1b4628a
--- /dev/null
@@ -0,0 +1,16 @@
+SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
+HOMEPAGE = "https://github.com/c0fec0de/anytree"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "anytree"
+
+SRC_URI[sha256sum] = "3f0f93f355a91bc3e6245319bf4c1d50e3416cc7a35cc1133c1ff38306bbccab"
+
+inherit pypi setuptools3
+
+do_install:append () {
+    rm -f ${D}${prefix}/LICENSE
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-deprecation_2.1.0.bb b/recipes-devtools/python/python3-deprecation_2.1.0.bb
new file mode 100644 (file)
index 0000000..c4b3a1c
--- /dev/null
@@ -0,0 +1,12 @@
+SUMMARY = "A library to handle automated deprecations"
+HOMEPAGE = "https://github.com/briancurtin/deprecation"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "deprecation"
+
+SRC_URI[sha256sum] = "72b3bde64e5d778694b0cf68178aed03d15e15477116add3fb773e581f9518ff"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-graphql-core_3.2.3.bb b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
new file mode 100644 (file)
index 0000000..b12957a
--- /dev/null
@@ -0,0 +1,12 @@
+SUMMARY = "GraphQL implementation for Python"
+HOMEPAGE = "https://github.com/graphql-python/graphql-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=73706fb002de2debc52328afd1688817"
+
+PYPI_PACKAGE = "graphql-core"
+
+SRC_URI[sha256sum] = "06d2aad0ac723e35b1cb47885d3e5c45e956a53bc1b209a9fc5369007fe46676"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"