cef: use vpython3 for commands called by gclient 59/29659/3 16.93.0 quillback/16.93.0 quillback_16.93.0
authorRoger Zanoni <rzanoni@igalia.com>
Mon, 5 Feb 2024 18:20:03 +0000 (15:20 -0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 7 Feb 2024 16:15:38 +0000 (16:15 +0000)
The probable cause for SPEC-5062 is that chromium's go routines that
create virtualenvs expect vpython environment variables to be present,
so the creation fails and the scripts could be trying to use the build
host python binary.

This can cause issues on some places, for example in the codecs lookup
that raises an exception when an codec isn't found:

https://github.com/pypa/pip/pull/6311/files

The exception raised on SPEC-5062 logs is "unknown encoding: utf-16le",
because the sysroot pip version expects "utf-16-le" instead.

Bug-AGL: SPEC-5062

Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: I16e817140bf819712a5fbe1b006156db608d43b2
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29659
ci-image-build: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

recipes-wam/cef/cef_git.bb

index 8227dd1..4a87631 100644 (file)
@@ -307,9 +307,9 @@ do_configure () {
 
     # Download a few dependencies.  Check the current chromium DEPS file when
     # upgrading to a new milestone.
-    python3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-fonts -s third_party/test_fonts/test_fonts.tar.gz.sha1
-    python3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-nodejs/16.13.0 -s third_party/node/linux/node-linux-x64.tar.gz.sha1
-    python3 tools/rust/update_rust.py
+    vpython3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-fonts -s third_party/test_fonts/test_fonts.tar.gz.sha1
+    vpython3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-nodejs/16.13.0 -s third_party/node/linux/node-linux-x64.tar.gz.sha1
+    vpython3 tools/rust/update_rust.py
 
     cd ${S}/cef
     python3 tools/gclient_hook.py --base-out-path ${B} --bypass-sysroot-check