webapps: Bump html5-mixer SRCREV 58/29658/4
authorRoger Zanoni <rzanoni@igalia.com>
Sat, 3 Feb 2024 18:27:55 +0000 (15:27 -0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 7 Feb 2024 16:15:38 +0000 (16:15 +0000)
Includes changes needed to make the application start using gRPC-WEB

Bug-AGL: SPEC-4599

Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: Ib9506453085ee36f446bcda3726595a47bb4593c
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29658
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-demo/html5-mixer/html5-mixer_git.bb

index 195478f..27c3e29 100644 (file)
@@ -11,7 +11,7 @@ B       = "${WORKDIR}/build"
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
 "
-SRCREV = "38587cf96c096a204cd742fff9fea4f8e465393a"
+SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
 
 inherit pythonnative agl-app
 
@@ -19,13 +19,14 @@ AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-mixer"
 AGL_APP_NAME = "HTML5 Mixer"
 
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native protobuf-native"
 
 do_compile[network] = "1"
 do_compile() {
   cd ${S}
   rm -rf package node_modules package-lock.json
   npm install
+  npm run generate-grpc
   npm run build
 }