python3-pyqt5: enable SVG support 45/29345/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 30 Oct 2023 21:47:48 +0000 (17:47 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 4 Nov 2023 14:37:10 +0000 (14:37 +0000)
Add a bbappend for python3-pyqt5 to enable its QtSvg module that
exposes Qt's SVG support.  This is required for
agl-demo-control-panel.

Bug-AGL: SPEC-4952

Change-Id: Ic8ae0816227306139b6e14cbe6974bcfeffcef7f
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29345
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-boot-test: Jenkins Job builder account
Tested-by: Jenkins Job builder account
Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com>
ci-image-build: Jenkins Job builder account

recipes-devtools/python/python3-pyqt5_5.15.1.bbappend [new file with mode: 0644]

diff --git a/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend b/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend
new file mode 100644 (file)
index 0000000..408c48b
--- /dev/null
@@ -0,0 +1,9 @@
+# Enable SVG support
+DEPENDS:append = " qtsvg"
+PYQT_MODULES:append = " QtSvg"
+
+# Fix python interpreter paths in pyrcc5, etc., adapted from newer upstream
+# recipe
+do_install:append() {
+    sed -i "s,^exec .*python${PYTHON_BASEVERSION},exec ${bindir}/python3," ${D}/${bindir}/*
+}