python3-qtwidgets: add recipe 44/29344/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 30 Oct 2023 21:46:59 +0000 (17:46 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 4 Nov 2023 14:37:10 +0000 (14:37 +0000)
Add recipe for python3-qtwidegts, it is needed for
agl-demo-control-panel.

Bug-AGL: SPEC-4952

Change-Id: Id8a10801da5f1a5faa1c7255bc1b3c914db0f1aa
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29344
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com>
Tested-by: Jenkins Job builder account
recipes-devtools/python/python3-qtwidgets_1.1.bb [new file with mode: 0644]

diff --git a/recipes-devtools/python/python3-qtwidgets_1.1.bb b/recipes-devtools/python/python3-qtwidgets_1.1.bb
new file mode 100644 (file)
index 0000000..677d4fa
--- /dev/null
@@ -0,0 +1,12 @@
+SUMMARY = "Custom Qt5 Python Widgets"
+HOMEPAGE = "https://github.com/pythonguis/python-qtwidgets"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dc687cb5e5291e09b4f52b0b182106fe"
+
+SRC_URI[sha256sum] = "97b8373844788a22c836f5a16a1e60c9ef1469bfc4aedc09ae786fc9aa0b49df"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-qtpy \
+"