[wam][cef] Add the depot-tools-wam-native recipe 35/29035/3
authorRoger Zanoni <rzanoni@igalia.com>
Thu, 22 Jun 2023 07:10:16 +0000 (09:10 +0200)
committerRoger Zanoni <rzanoni@igalia.com>
Tue, 18 Jul 2023 13:28:38 +0000 (15:28 +0200)
This is needed by the CEF recipe in order to retrieve chromium
dependencies.

Bug-AGL: SPEC-3872

Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: I4aa73859e3578db92cbc72945ca86c812a12376f

recipes-wam/depot_tools/depot-tools-wam-native_git.bb [new file with mode: 0644]

diff --git a/recipes-wam/depot_tools/depot-tools-wam-native_git.bb b/recipes-wam/depot_tools/depot-tools-wam-native_git.bb
new file mode 100644 (file)
index 0000000..9a466bb
--- /dev/null
@@ -0,0 +1,32 @@
+SUMMARY = " A collection of tools for dealing with Chromium development"
+DESCRIPTION = "The Chromium depot_tools suite contains many tools to assist/augment the Chromium development environment."
+HOMEPAGE = "https://commondatastorage.googleapis.com/chrome-infra-docs/flat/depot_tools/docs/html/depot_tools_tutorial.html"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c2c05f9bdd5fc0b458037c2d1fb8d95e"
+
+SRC_URI = "git://chromium.googlesource.com/chromium/tools/depot_tools.git;protocol=https;branch=main"
+SRCREV = "64b61755572b1d03b3a43f1a29b617dcae3a3fe0"
+
+S = "${WORKDIR}/git"
+
+inherit native
+
+do_compile[network] = "1"
+do_compile() {
+    export PATH=${S}:$PATH
+    ./ensure_bootstrap
+}
+
+do_install() {
+    install -d ${D}${datadir}/depot_tools
+    cp -aR --no-dereference --no-preserve=owner ${WORKDIR}/git/. ${D}${datadir}/depot_tools
+}
+
+INSANE_SKIP:${PN} += "already-stripped file-rdeps"
+
+BBCLASSEXTEND = "native"
+
+FILES:${PN}-dev += " \
+  ${datadir}/depot_tools/* \
+"