[wam][cef] Add the depot-tools-wam-native recipe
[AGL/meta-agl-demo.git] / recipes-wam / depot_tools / depot-tools-wam-native_git.bb
1 SUMMARY = " A collection of tools for dealing with Chromium development"
2 DESCRIPTION = "The Chromium depot_tools suite contains many tools to assist/augment the Chromium development environment."
3 HOMEPAGE = "https://commondatastorage.googleapis.com/chrome-infra-docs/flat/depot_tools/docs/html/depot_tools_tutorial.html"
4
5 LICENSE = "BSD-3-Clause"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=c2c05f9bdd5fc0b458037c2d1fb8d95e"
7
8 SRC_URI = "git://chromium.googlesource.com/chromium/tools/depot_tools.git;protocol=https;branch=main"
9 SRCREV = "64b61755572b1d03b3a43f1a29b617dcae3a3fe0"
10
11 S = "${WORKDIR}/git"
12
13 inherit native
14
15 do_compile[network] = "1"
16 do_compile() {
17     export PATH=${S}:$PATH
18     ./ensure_bootstrap
19 }
20
21 do_install() {
22     install -d ${D}${datadir}/depot_tools
23     cp -aR --no-dereference --no-preserve=owner ${WORKDIR}/git/. ${D}${datadir}/depot_tools
24 }
25
26 INSANE_SKIP:${PN} += "already-stripped file-rdeps"
27
28 BBCLASSEXTEND = "native"
29
30 FILES:${PN}-dev += " \
31   ${datadir}/depot_tools/* \
32 "