wayland: add .desktop file for weston-terminal 42/26942/5
authorArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 7 Dec 2021 18:16:00 +0000 (19:16 +0100)
committerArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 21 Dec 2021 08:03:16 +0000 (09:03 +0100)
weston-terminal is already installed as part of the weston installation.
However, it doesn't provide a way to be easily discovered. This commit
creates a .desktop file following the "Desktop entry specification" so
this application can be discovered by a compliant application launcher.

Bug-AGL: SPEC-4161
Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Change-Id: I9c413645ed0bd4371c7d18977304ef6f1a5a2be7

recipes-graphics/wayland/weston-terminal-conf.bb [new file with mode: 0644]
recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-graphical-weston_agldemo.inc

diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
new file mode 100644 (file)
index 0000000..4bf864f
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "AGL user session"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+    file://weston-terminal.desktop \
+"
+
+inherit allarch
+
+do_install() {
+    install -d ${D}${datadir}/applications
+    install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications
+}
+
+FILES:${PN} = "${datadir}/applications"
+
+RDEPENDS:${PN} = " \
+    weston \
+"
diff --git a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
new file mode 100644 (file)
index 0000000..6c46287
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=Weston Terminal
+Comment=Terminal Emulator
+GenericName=Terminal Emulator
+Exec=weston-terminal
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
+StartupNotify=true
index 7db76c6..9c2feca 100644 (file)
@@ -2,4 +2,5 @@ RDEPENDS:${PN}_remove = "weston-init"
 
 RDEPENDS:${PN} += " \
                   agl-compositor \
+                  weston-terminal-conf \
                   "