Workaround issue with homescreen-demo-ci with AGLCI on 59/25759/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 7 Dec 2020 10:15:54 +0000 (11:15 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 7 Dec 2020 10:28:27 +0000 (10:28 +0000)
Ensure we can build master with AGLCI on.

This fixes:
Error:
 Problem: package packagegroup-agl-demo-platform-1.0-r0.noarch requires packagegroup-hmi-framework, but none of the providers can be installed
  - conflicting requests
  - nothing provides homescreen-demo-ci needed by packagegroup-hmi-framework-1.0-2.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

until we can debug the root cause.

Bug-AGL: SPEC-3718
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Ide1836430622f91a34a7acb012c444b26c983505

recipes-platform/packagegroups/packagegroup-hmi-framework.bb

index c5ea9fd..6061bf4 100644 (file)
@@ -24,7 +24,8 @@ RDEPENDS_${PN} = " \
   launcher \
 "
 
-RDEPENDS_append_${PN} = " ${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'homescreen-demo-ci', '', d)}"
+# temporarily disable due to failure to install package when AGLCI is on
+#RDEPENDS_append_${PN} = " ${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'homescreen-demo-ci', '', d)}"
 
 # NOTE: Currently no coverage versions of these widgets, they should
 #       be added here when available.