Workaround issue with homescreen-demo-ci with AGLCI on
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-hmi-framework.bb
1 SUMMARY = "The software for the AGL hmi framework 2017"
2 DESCRIPTION = "A set of packages belong to the hmi framework 2017"
3
4 LICENSE = "MIT"
5
6 # need to bump manually due to:
7 # - nothing provides libqthomescreenwrapper0 needed by packagegroup-hmi-framework-1.0-r0.noarch
8 PR = "2"
9
10 inherit packagegroup
11
12 PROVIDES = "${PACKAGES}"
13 PACKAGES = "\
14     packagegroup-hmi-framework \
15     packagegroup-hmi-framework-devel \
16     "
17
18 RDEPENDS_${PN} = " \
19   agl-service-homescreen \
20   homescreen \
21   libhomescreen \
22   qlibhomescreen \
23   hmi-debug \
24   launcher \
25 "
26
27 # temporarily disable due to failure to install package when AGLCI is on
28 #RDEPENDS_append_${PN} = " ${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'homescreen-demo-ci', '', d)}"
29
30 # NOTE: Currently no coverage versions of these widgets, they should
31 #       be added here when available.
32 RDEPENDS_${PN}-devel = " \
33   agl-service-homescreen-dbg \
34   homescreen-dbg \
35   launcher-dbg \
36 "