agl-ivi-demo-platform-flutter: add ondemandnavi 01/29701/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 20 Feb 2024 20:52:31 +0000 (15:52 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 8 Mar 2024 18:27:03 +0000 (18:27 +0000)
Add ondemandnavi application to new default Flutter demo image, and
update both it and tbtnavi's runtime dependencies to make sure all
the required Qt packages get pulled into the image.

Bug-AGL: SPEC-5085

Change-Id: I521a7e3a1d161f2283023f8fa346092f961ac4ba
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29701
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
recipes-demo/navigation/ondemandnavi_git.bb
recipes-demo/navigation/tbtnavi_git.bb
recipes-platform/images/agl-ivi-demo-platform-flutter.bb

index 3baac2a..5fa27aa 100644 (file)
@@ -37,6 +37,13 @@ do_install:append() {
 }
 
 RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols-qmlplugins \
+    qtquickcontrols2-qmlplugins \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
     qtlocation \
     flite \
     libqtappfw \
index 1720e89..b621381 100644 (file)
@@ -53,6 +53,9 @@ do_install:append() {
 }
 
 RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
     qtlocation \
     ondemandnavi-config \
     libqtappfw \
index 82e3288..a50c00b 100644 (file)
@@ -4,4 +4,5 @@ DESCRIPTION = "AGL Flutter Demo Platform image"
 
 AGL_APPS_INSTALL += " \
     flutter-ics-homescreen \
+    ondemandnavi \
 "