Add dummy recipes for UI components. 47/4247/3
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Tue, 3 Nov 2015 21:49:49 +0000 (22:49 +0100)
committerGerrit Code Review <gerrit@172.30.200.200>
Wed, 4 Nov 2015 20:43:44 +0000 (20:43 +0000)
Change-Id: I221367d457685f026c3fee84594a2b25b08ef6e9
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/HVAC/HVAC.bb [new file with mode: 0644]
recipes-demo-hmi/HomeScreen/HomeScreen.bb [new file with mode: 0644]
recipes-demo-hmi/MediaPlayer/MediaPlayer.bb [new file with mode: 0644]
recipes-demo-hmi/Settings/Settings.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/HVAC/HVAC.bb b/recipes-demo-hmi/HVAC/HVAC.bb
new file mode 100644 (file)
index 0000000..681b84f
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION     = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE     = "xyz"
+# Dummy MPL-2.0
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV      = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    true
+}
+
+# empty folder for now
+do_install() {
+    mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen.bb b/recipes-demo-hmi/HomeScreen/HomeScreen.bb
new file mode 100644 (file)
index 0000000..681b84f
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION     = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE     = "xyz"
+# Dummy MPL-2.0
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV      = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    true
+}
+
+# empty folder for now
+do_install() {
+    mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/MediaPlayer/MediaPlayer.bb b/recipes-demo-hmi/MediaPlayer/MediaPlayer.bb
new file mode 100644 (file)
index 0000000..681b84f
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION     = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE     = "xyz"
+# Dummy MPL-2.0
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV      = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    true
+}
+
+# empty folder for now
+do_install() {
+    mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/Settings/Settings.bb b/recipes-demo-hmi/Settings/Settings.bb
new file mode 100644 (file)
index 0000000..681b84f
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION     = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE     = "xyz"
+# Dummy MPL-2.0
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV      = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    true
+}
+
+# empty folder for now
+do_install() {
+    mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"