radio: update recipe for switch to radio binding 77/9477/4
authorScott Murray <scott.murray@konsulko.com>
Mon, 22 May 2017 22:15:01 +0000 (18:15 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 25 May 2017 12:53:51 +0000 (12:53 +0000)
Building the radio application has some different dependencies with the
switch to using a binding instead of qtmultimedia.  Update DEPENDS and
RDEPENDS to reflect the changes.

Bug-AGL: SPEC-581

Change-Id: I610b580f54d4348cd27ada3eaee4711f02d94df6
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/radio/radio_git.bb

index 86ffe8c..ca75f2d 100644 (file)
@@ -3,8 +3,9 @@ DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LICENSE     = "Apache-2.0 & GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+                    file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=http \
            file://presets-ALS.conf \
@@ -17,7 +18,7 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 qtmultimedia"
+DEPENDS = "qtquickcontrols2 rtl-sdr glib-2.0 pulseaudio alsa-lib"
 
 inherit qmake5 aglwgt
 
@@ -36,8 +37,3 @@ FILES_${PN} += " \
        /home/root/app-data/radio/presets-*.conf \
        /home/root/app-data/radio/presets.conf \
 "
-
-RDEPENDS_${PN} += " \
-    qtmultimedia-qmlplugins \
-    qtmultimedia-rtlfm-radio-plugin \
-"