Add audio management between Media Player and Radio. 99/9499/2
authorToshiaki Isogai <isogai.toshiaki@nttd-mse.com>
Tue, 24 Jan 2017 09:00:37 +0000 (18:00 +0900)
committerScott Murray <scott.murray@konsulko.com>
Wed, 24 May 2017 13:53:58 +0000 (13:53 +0000)
This patch enables loading router-module by default to manage audio routing
when both Media Player and Radio start playing.
Latter audio source selected by user enforces existing one corked.

Detail in below.
https://jira.automotivelinux.org/browse/SPEC-378

Bug-AGL: SPEC-606

Change-Id: I407924b1346f95573596434ba9b17c732cae5146
Signed-off-by: Toshiaki Isogai <isogai.toshiaki@nttd-mse.com>
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-multimedia/audiomanager-plugins-config/audiomanager-plugins-config/configuration.xml
recipes-multimedia/audiomanager-plugins-config/audiomanager-plugins-config_7.4.bb
recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch [new file with mode: 0644]
recipes-multimedia/pulseaudio/pulseaudio_%.bbappend [new file with mode: 0644]

index 3df7d5c..9e2d05e 100644 (file)
           <type>ACTION_LIMIT</type>
           <param>
             <className>"BASE"</className>
-            <volume>-2500</volume>
+            <volume>-1000</volume>
             <pattern>01</pattern>
           </param>
         </action>
             <type>ACTION_LIMIT</type>
             <param>
               <className>"BASE"</className>
-              <volume>-2500</volume>
+              <volume>-1000</volume>
               <pattern>02</pattern>
             </param>
           </action>
index b8b76ec..8e5edd8 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION = "Configurations for Audiomanager Plugins for AGL Demo"
 HOMEPAGE = ""
-LICENSE = "Proprietary"
+LICENSE = "MPLv2"
 SECTION = "multimedia"
 
-LIC_FILES_CHKSUM = "file://${WORKDIR}/configuration.xml;md5=97090515005265aca5bddffcee4bc8a1"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
 RDEPENDS_${PN} = "libxml2 zlib dbus-lib"
 
 SRC_URI = " \
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch b/recipes-multimedia/pulseaudio/pulseaudio/0006-auto-load-module-router.patch
new file mode 100644 (file)
index 0000000..e1ae914
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/src/daemon/default.pa.in b/src/daemon/default.pa.in
+index 783e326..3c68638 100755
+--- a/src/daemon/default.pa.in
++++ b/src/daemon/default.pa.in
+@@ -35,9 +35,9 @@ load-sample-dir-lazy %WINDIR%\Media\*.wav
+ .fail
+ ### Automatically restore the volume of streams and devices
+-load-module module-device-restore
+-load-module module-stream-restore
+-load-module module-card-restore
++#load-module module-device-restore
++#load-module module-stream-restore
++#load-module module-card-restore
+ ### Automatically augment property information from .desktop files
+ ### stored in /usr/share/application
+@@ -195,3 +195,8 @@ ifelse(@HAVE_X11@, 1, [dnl
+ ### Make some devices default
+ #set-default-sink output
+ #set-default-source input
++
++.ifexists module-router.so
++load-module module-router
++.endif
++
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
new file mode 100644 (file)
index 0000000..8ff6a73
--- /dev/null
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0006-auto-load-module-router.patch"