Finalize and automate sllin setup for LIN on demo unit 83/17783/7
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 7 Nov 2018 07:08:43 +0000 (08:08 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 13 Nov 2018 18:15:24 +0000 (18:15 +0000)
Provide the systemd unit, the init script, the module options and the autoload command.

Change-Id: I8dfe59338f377ca8ac1b94fe568dff9e2b36bf97
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-kernel/sllin/files/sllin-demo.service [new file with mode: 0644]
recipes-kernel/sllin/files/start_lin_demo.sh [new file with mode: 0755]
recipes-kernel/sllin/sllin.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-kernel/sllin/files/sllin-demo.service b/recipes-kernel/sllin/files/sllin-demo.service
new file mode 100644 (file)
index 0000000..c1bc949
--- /dev/null
@@ -0,0 +1,13 @@
+[Unit]
+Description = LIN DEMO startup
+After=afm-system-daemon.service
+[Service]
+Type=forking
+PIDFile=/var/run/lin_ldattach
+ExecStart=/usr/bin/start_lin_demo.sh
+RemainAfterExit=yes
+
+[Install]
+WantedBy=default.target
diff --git a/recipes-kernel/sllin/files/start_lin_demo.sh b/recipes-kernel/sllin/files/start_lin_demo.sh
new file mode 100755 (executable)
index 0000000..741189f
--- /dev/null
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+sleep 1
+ldattach 25 /dev/ttySC3
+pidof ldattach > /var/run/lin_ldattach
+sleep 1
+ip link set sllin0 up
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 02A#
+usleep 100000
+cansend sllin0 02B#
+usleep 100000
+cansend sllin0 032#F0F8FFFFFFFFFFFF
+usleep 100000
+cansend sllin0 032#F0F8FFFFFFFFFFFF
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 030#
+usleep 100000
+cansend sllin0 02D#
+usleep 100000
+cansend sllin0 02C#
+usleep 100000
+cansend sllin0 02D#
+usleep 100000
+cansend sllin0 02C#
+usleep 100000
+
index eecd439..f7ffea9 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "slLIN driver module"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-inherit module
+inherit module systemd
 
 DEPENDS = "virtual/kernel"
 
@@ -16,6 +16,23 @@ SRC_URI_append = " \
        file://0001_update_makefile.patch;pnum=2 \
        file://0002_fix_null_operation_check.patch;pnum=2 \
        file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
+       file://sllin-demo.service \
+       file://start_lin_demo.sh \
 "
 
+KERNEL_MODULE_AUTOLOAD_append = " sllin"
+KERNEL_MODULE_PROBECONF_append = " sllin"
 
+SLLINBAUDRATE ??= "9600"
+module_conf_sllin = "options sllin baudrate=${SLLINBAUDRATE}"
+
+SYSTEMD_SERVICE_${PN} = "sllin-demo.service"
+
+do_install_append () {
+       install -d 644 ${D}/${bindir}
+       install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
+       install -d ${D}${systemd_system_unitdir}
+       install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
+}
+
+FILES_${PN}_append = " ${bindir}/start_lin_demo.sh"
index d79a36b..f3191ca 100755 (executable)
@@ -22,8 +22,8 @@ RDEPENDS_${PN} += "\
 
 MOST_DRIVERS = " \
     most \
-    sllin \
     "
+MOST_DRIVERS_append_m3ulcb = " sllin"
 
 # HVAC dependencies depend on drivers above
 MOST_HVAC = " "