Finalize and automate sllin setup for LIN on demo unit
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-ivi \
16     "
17
18 RDEPENDS_${PN} += "\
19     packagegroup-agl-profile-graphical-qt5 \
20     packagegroup-agl-demo \
21     "
22
23 MOST_DRIVERS = " \
24     most \
25     "
26 MOST_DRIVERS_append_m3ulcb = " sllin"
27
28 # HVAC dependencies depend on drivers above
29 MOST_HVAC = " "
30 MOST_HVAC_append = " \
31     ${MOST_DRIVERS} \
32     unicens-config \
33     agl-service-unicens \
34     "
35
36 # @Chris: This needs to be checked!
37 MOST_HVAC_dra7xx-evm = ""
38 MOST_HVAC_dragonboard-410c = ""
39
40 # mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
41 MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
42
43 AGL_APPS = " \
44     dashboard \
45     hvac \
46     mediaplayer \
47     virtual/mixer  \
48     virtual/navigation \
49     phone \
50     poiapp \
51     radio \
52     settings \
53     high-level-viwi-service \
54     agl-service-signal-composer \
55     low-can-demo \
56     "
57
58 AGL_APIS = " \
59     libnaviapi-agl \
60     "
61
62 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
63
64 RDEPENDS_${PN}_append = " \
65     qtquickcontrols2-agl \
66     qtquickcontrols2-agl-style \
67     linux-firmware-ralink \
68     ${QTAGLEXTRAS} \
69     ${MAPVIEWER} \
70     ${MOST_HVAC} \
71     ${AGL_APPS} \
72     ${AGL_APIS} \
73     "
74
75