agl-demo-platform-crosssdk: add gcc-sanitizer to TOOLCHAIN_TARGET_TASK 14/23314/2
authorMatt Ranostay <matt.ranostay@konsulko.com>
Wed, 11 Dec 2019 05:50:19 +0000 (07:50 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 12 Dec 2019 13:53:33 +0000 (13:53 +0000)
Add gcc-sanitizers package to TOOLCHAIN_TARGET_TASK which allows linking of
libasan for detecting use-after-free and other memory corruption issue in
built applications/libraries.

Bug-AGL: SPEC-3040
Change-Id: Idad618e2bd0e9fa98baa9a3befc694c5bddeb711
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index dcd8848..a814b69 100755 (executable)
@@ -74,3 +74,8 @@ TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
 # other users of the C++17 filesystem standard library feature.
 # Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
 TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"