dashboard: update dependencies 25/23325/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 11 Dec 2019 19:43:17 +0000 (19:43 +0000)
committerScott Murray <scott.murray@konsulko.com>
Wed, 11 Dec 2019 21:41:00 +0000 (21:41 +0000)
Add libqtappfw to DEPENDS for dashboard app for signal composer
event support, and to RDEPENDS as well as new runtime dependency
agl-service-signal-composer.

Bug-AGL: SPEC-3042

Change-Id: I955f821798d85fbb0f9265ee55b81ff0bd7db620
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/dashboard/dashboard_git.bb

index 7ccbdea..822207b 100644 (file)
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native qtaglextras"
+DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
 
 inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += " \
+       libqtappfw \
+       agl-service-signal-composer \
+"