agl-demo-platform-html5: Create new image 89/23289/1
authorJacobo Aragunde Pérez <jaragunde@igalia.com>
Mon, 9 Dec 2019 17:13:44 +0000 (18:13 +0100)
committerJacobo Aragunde Pérez <jaragunde@igalia.com>
Mon, 9 Dec 2019 17:25:54 +0000 (18:25 +0100)
Add new image called agl-demo-platform-html5, which contains the web
application runtime and HTML demo apps.

Currently, only the HTML launcher is available, but more will be
published.

Bug-AGL: SPEC-2322

Change-Id: I4628d1be18f64b7eaf4a0882a13bd1d680426516
Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
recipes-platform/images/agl-demo-platform-html5.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb [new file with mode: 0644]

diff --git a/recipes-platform/images/agl-demo-platform-html5.bb b/recipes-platform/images/agl-demo-platform-html5.bb
new file mode 100644 (file)
index 0000000..2d3490f
--- /dev/null
@@ -0,0 +1,14 @@
+SUMMARY = "DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Contains the web runtime and sample web apps"
+
+require agl-demo-platform.inc
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES_append = " \
+    "
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL_append = " \
+    packagegroup-agl-demo-platform-html5 \
+    "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
new file mode 100644 (file)
index 0000000..8352b72
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-demo-platform-html5 \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-image-ivi \
+    packagegroup-agl-profile-graphical-html5 \
+    packagegroup-agl-demo \
+    "
+
+AGL_APPS = " \
+    html5-launcher \
+    "
+
+RDEPENDS_${PN}_append = " \
+    ${AGL_APPS} \
+    "