libqtappfw: clean up syntax and unused FILES* bits 37/11837/2
authorMatt Porter <mporter@konsulko.com>
Fri, 10 Nov 2017 19:24:18 +0000 (21:24 +0200)
committerMatt Porter <mporter@konsulko.com>
Fri, 10 Nov 2017 19:47:37 +0000 (19:47 +0000)
Fix some unnecessary whitespace and remove all the explicit
FILES* additions. These are all handled by the defaults.

Bug-AGL: SPEC-1064

Change-Id: I3b610cf503f938c84b17d514bb1ed1cf3f8607bb
Signed-off-by: Matt Porter <mporter@konsulko.com>
recipes-demo-hmi/libqtappfw/libqtappfw_git.bb

index 27f695d..53519c8 100644 (file)
@@ -4,11 +4,11 @@ HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "libs"
 
-BBCLASSEXTEND = " nativesdk"
+BBCLASSEXTEND = "nativesdk"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS += " qtbase qtwebsockets "
+DEPENDS += "qtbase qtwebsockets"
 
 inherit cmake_qt5
 
@@ -18,18 +18,3 @@ S       = "${WORKDIR}/git/"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "0.0+git${SRCPV}"
-
-FILES_${PN} = "\
-       ${libdir}/libqtappfw.so.* \
-"
-FILES_${PN}-dev = "\
-       ${includedir}/qtappfw/message.h \
-       ${includedir}/qtappfw/messageengine.h \
-       ${includedir}/qtappfw/telephonymessage.h \
-       ${includedir}/qtappfw/telephony.h \
-       ${libdir}/libqtappfw.so \
-       ${libdir}/pkgconfig/qtappfw.pc \
-"
-FILES_${PN}-dbg += "\
-       ${libdir}/.debug/libqtappfw.so.* \
-"