Add AGL libqtappfw to the platform 85/11785/3
authorMatt Porter <mporter@konsulko.com>
Thu, 9 Nov 2017 14:45:44 +0000 (16:45 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 10 Nov 2017 14:35:09 +0000 (14:35 +0000)
Add libqtappfw to the platform. This supports SDK development and
runtime of apps leveraging libqtappfw.

Bug-AGL: SPEC-1064

Change-Id: I7fc54fc7d9c4db885cd79d899bd40f44e4543766
Signed-off-by: Matt Porter <mporter@konsulko.com>
recipes-demo-hmi/libqtappfw/libqtappfw_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo.bb

diff --git a/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb b/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
new file mode 100644 (file)
index 0000000..27f695d
--- /dev/null
@@ -0,0 +1,35 @@
+SUMMARY     = "AGL Qt AppFW Library"
+DESCRIPTION = "libqtappfw"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+LICENSE     = "Apache-2.0"
+SECTION     = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS += " qtbase qtwebsockets "
+
+inherit cmake_qt5
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "112fc8be473f02befc7596750ad7044113f29849"
+S       = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+FILES_${PN} = "\
+       ${libdir}/libqtappfw.so.* \
+"
+FILES_${PN}-dev = "\
+       ${includedir}/qtappfw/message.h \
+       ${includedir}/qtappfw/messageengine.h \
+       ${includedir}/qtappfw/telephonymessage.h \
+       ${includedir}/qtappfw/telephony.h \
+       ${libdir}/libqtappfw.so \
+       ${libdir}/pkgconfig/qtappfw.pc \
+"
+FILES_${PN}-dbg += "\
+       ${libdir}/.debug/libqtappfw.so.* \
+"
index cc93dda..186280e 100644 (file)
@@ -21,6 +21,7 @@ HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
 
 RDEPENDS_${PN} += "\
     packagegroup-agl-appfw \
+    libqtappfw \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
     udisks \
     ${SMARTDEVICELINK} \