Adding the cannelloni tool for can over ethernet to agl-demo 14/25714/2
authorThomas Walzer <Thomas.Walzer@Reutlingen-University.DE>
Wed, 2 Dec 2020 15:14:35 +0000 (16:14 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 7 Dec 2020 15:46:24 +0000 (15:46 +0000)
It could be used via cli cannelloni

Bug-AGL: [SPEC-3698]

Signed-off-by: Thomas Walzer <Thomas.Walzer@Reutlingen-University.DE>
Change-Id: Id07dcaf440a5b205da3ab120f4744866c4ff36de

recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch [new file with mode: 0644]
recipes-connectivity/cannelloni/cannelloni_git.bb [new file with mode: 0644]

diff --git a/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch b/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch
new file mode 100644 (file)
index 0000000..b5e59e6
--- /dev/null
@@ -0,0 +1,24 @@
+From f3b356b1ecd6c5401537f593ce373a5b76eb8a9d Mon Sep 17 00:00:00 2001
+From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+Date: Tue, 17 Nov 2020 16:06:20 +0100
+Subject: [PATCH] Fix compilation on latest gcc versions
+
+Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 51fa256..7e977d1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,7 +6,8 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
+ # Options
+ option(SCTP_SUPPORT "SCTP_SUPPORT" ON)
+-set(CMAKE_CXX_FLAGS -Wall)
++#set(CMAKE_CXX_FLAGS -Wall)
++set(CMAKE_CXX_STANDARD 11)
+ if(SCTP_SUPPORT)
+   include(FindSCTP)
diff --git a/recipes-connectivity/cannelloni/cannelloni_git.bb b/recipes-connectivity/cannelloni/cannelloni_git.bb
new file mode 100644 (file)
index 0000000..507dbf0
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "A SocketCAN over Ethernet tunnel"
+HOMEPAGE = "https://github.com/mguentner/cannelloni"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
+           file://0001-Fix-compilation-on-latest-gcc-versions.patch \
+           "
+
+PV = "1.0.0+git${SRCPV}"
+SRCREV = "aa0f0ecba2b8be0ea7ddd9952e719449a75330ec"
+
+S = "${WORKDIR}/git"
+
+inherit cmake