Remove meta-python dependencies 45/29745/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 18 Mar 2024 21:16:12 +0000 (17:16 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 19 Mar 2024 11:44:32 +0000 (11:44 +0000)
Remove remaining meta-python dependencies from layer and recipe
configuration.  The agl-ivi-demo-platform-html5 image has been
confirmed to build with these changes, and they are a prerequisite
for removing meta-python from the repo manifest.

Bug-AGL: SPEC-5099

Change-Id: I1d8ff343eef2d883bbc5b5baf0f7b69b161faf94
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29745
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

13 files changed:
conf/layer.conf
recipes-demo/html5-background/html5-background_git.bb
recipes-demo/html5-dashboard/html5-dashboard_git.bb
recipes-demo/html5-homescreen/html5-homescreen_git.bb
recipes-demo/html5-hvac/html5-hvac_git.bb
recipes-demo/html5-launcher/html5-launcher_git.bb
recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
recipes-demo/html5-mixer/html5-mixer_git.bb
recipes-demo/html5-settings/html5-settings_git.bb
recipes-demo/webapp-samples/html5-aquarium_git.bb
recipes-demo/webapp-samples/html5-examples_git.bb
recipes-demo/webapp-samples/html5-jitsi_git.bb
recipes-demo/webapp-samples/html5-youtube_git.bb

index 501ab80..8a937a8 100644 (file)
@@ -16,4 +16,4 @@ BBFILES_DYNAMIC += " \
 
 LAYERSERIES_COMPAT_agldemo = "kirkstone"
 
-LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer meta-flutter meta-python2 meta-app-framework multimedia-layer"
+LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer multimedia-layer meta-flutter meta-app-framework"
index 4e6bb14..c848710 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "aa7e2a81e91ed076c0bc9ba07db5aee0f34668df"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-${BPN}"
index 1a2b5c9..586627c 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "38befd7704f64781bf4bce85fd9b2cdffc7845fa"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-dashboard"
index 567d1d6..2c46b95 100644 (file)
@@ -14,7 +14,7 @@ PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
-inherit pythonnative systemd
+inherit systemd
 
 DEPENDS = "nodejs-native"
 
index 2503e7c..c0d4c54 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "c323ab8fde212120d8d1914d453afeb55b3576e5"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-hvac"
index a50c175..cc9143c 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "ccdd59db7dc073eee0a35d0318640d9833824073"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "launcher"
index 7c39f37..c178052 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "b87776912cc31c976415ceb49e7551f500e0975b"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-mediaplayer"
index 27c3e29..fe45ef1 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-mixer"
index c8dae72..ff94276 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = " \
 "
 SRCREV = "69af4d9b9b209fcb33ef9071ddfa8561106044c2"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-settings"
index 7828ecc..0afc851 100644 (file)
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-aquarium.json"
 
 require webapp-samples.inc
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-aquarium"
index 080331e..c2b131a 100644 (file)
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-examples.json"
 
 require webapp-samples.inc
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-examples"
index e24ff32..e382cb0 100644 (file)
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-jitsi.json"
 
 require webapp-samples.inc
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-jitsi"
index 240ce85..44a9644 100644 (file)
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-youtube.json"
 
 require webapp-samples.inc
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-youtube"