Remove meta-python dependencies
[AGL/meta-agl-demo.git] / recipes-demo / html5-mixer / html5-mixer_git.bb
1 SUMMARY     = "AGL HTML5 mixer Application"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mixer/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
13 "
14 SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
15
16 inherit agl-app
17
18 AGL_APP_TEMPLATE = "agl-app-web"
19 AGL_APP_ID = "webapps-mixer"
20 AGL_APP_NAME = "HTML5 Mixer"
21
22 DEPENDS = "nodejs-native protobuf-native"
23
24 do_compile[network] = "1"
25 do_compile() {
26   cd ${S}
27   rm -rf package node_modules package-lock.json
28   npm install
29   npm run generate-grpc
30   npm run build
31 }
32
33 WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
34
35 do_install() {
36   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
37   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
38 }
39
40 FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"