agl-service-bluetooth: add missing DEPENDS and RDEPENDS dependencies 53/13753/1
authorMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 10 Apr 2018 03:05:59 +0000 (20:05 -0700)
committerMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 10 Apr 2018 03:09:27 +0000 (20:09 -0700)
Add missing json-c and glib-2.0 to DEPENDS, and agl-service-data-persistence
to RDEPENDS for data storage.

Change-Id: I048d59d3f3d9b7dc50672999e1ca9fedffa8eb7d
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-demo-hmi/agl-service-bluetooth/agl-service-bluetooth_git.bb

index 0ecc10e..da0e809 100644 (file)
@@ -12,4 +12,7 @@ SRCREV  = "${AGL_APP_REVISION}"
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
+DEPENDS = "glib-2.0 json-c"
+RDEPENDS_${PN} = "agl-service-data-persistence"
+
 inherit cmake aglwgt pkgconfig