Upgrade to pyro 55/10455/6
authorChanghyeok Bae <changhyeok.bae@gmail.com>
Thu, 1 Jun 2017 07:46:15 +0000 (07:46 +0000)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 6 Sep 2017 11:26:25 +0000 (13:26 +0200)
wayland-ivi-extension: Arrange recipe
- Remove unecessary variable in PACKAGECONFIG
- Arrange test-path.patch to upgrade wayland-ivi-extension

qtbase: Fix build error due to binutils 2.28 bug
- gold linker from binutils 2.28 may produce duplicate library
  symbols, which makes shared libraries created with it not usable
  with conventional ld linker.
- See https://bugs.freebsd.org/bugzilla/attachment.cgi?id=183069&action=diff

weston: Change recipe version

libdbus-c++: Remove recipe and add bbappend file
- meta-openembedded (pyro) already has same version.
- Remove PNBLACKLIST[libdbus-c++] to use this component.

packagegroups / agl-demo.inc :
- move inclusion of qtwebkit out of agl-demo.inc into packagegroup-agl-demo
- this fixes an inclusion bug

Bug-AGL: SPEC-646

Change-Id: Ia71d5f4dc881f0d8f8f24a5574c9efc0f2da6245
Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
14 files changed:
conf/include/agl-demo.inc
recipes-core/dbus/libdbus-c++-0.9.0/0001-src-eventloop.cpp-use-portable-method-for-initializi.patch [deleted file]
recipes-core/dbus/libdbus-c++-0.9.0/0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch [deleted file]
recipes-core/dbus/libdbus-c++-0.9.0/0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch [deleted file]
recipes-core/dbus/libdbus-c++-0.9.0/0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch [deleted file]
recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch [deleted file]
recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch [deleted file]
recipes-core/dbus/libdbus-c++_0.9.0.bb [deleted file]
recipes-core/dbus/libdbus-c++_0.9.0.bbappend [new file with mode: 0644]
recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
recipes-graphics/wayland/weston_%.bbappend [moved from recipes-graphics/wayland/weston_1.11.0.bbappend with 100% similarity]
recipes-platform/packagegroups/packagegroup-agl-demo.bb
recipes-qt/qt5/qtbase_%.bbappend

index dbe80f1..2b6a2ce 100644 (file)
@@ -3,14 +3,4 @@ IMAGE_FEATURES =+ "debug-tweaks"
 DISTRO_FEATURES_append = " webruntime "
 DISTRO_FEATURES_append = " automount "
 
-# Add webkit as workaround as webengine is broken right now
-IMAGE_INSTALL_append = " qtwebkit qtwebkit-examples-examples"
-#IMAGE_INSTALL_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
-#IMAGE_INSTALL_append = " qtwebengine-examples"
-
-# add support for websocket in Qt and QML
-IMAGE_INSTALL_append = " qtwebsockets qtwebsockets-qmlplugins"
-
-IMAGE_INSTALL_append = " screen "
-
-PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
+IMAGE_INSTALL_append = " screen mc "
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/0001-src-eventloop.cpp-use-portable-method-for-initializi.patch b/recipes-core/dbus/libdbus-c++-0.9.0/0001-src-eventloop.cpp-use-portable-method-for-initializi.patch
deleted file mode 100644 (file)
index eed84e4..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 93fd4868d71aa7a26cdfd382d1e4c85112f069f9 Mon Sep 17 00:00:00 2001
-From: Peter Williams <peter@newton.cx>
-Date: Sat, 19 Dec 2015 21:07:37 -0500
-Subject: [PATCH] src/eventloop.cpp: use portable method for initializing
- recursive mutex
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
----
-Upstream-Status: Backport [https://github.com/andreas-volz/dbus-cplusplus/commit/cdaeaa825db191bd65aad3aaaeb3178738727f05]
-Signed-off-by: André Draszik <adraszik@tycoint.com>
- src/eventloop.cpp | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/src/eventloop.cpp b/src/eventloop.cpp
-index 7fb06a3..f622812 100644
---- a/src/eventloop.cpp
-+++ b/src/eventloop.cpp
-@@ -85,8 +85,11 @@ DefaultMutex::DefaultMutex(bool recursive)
- {
-   if (recursive)
-   {
--    pthread_mutex_t recmutex = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
--    _mutex = recmutex;
-+    pthread_mutexattr_t attr;
-+
-+    pthread_mutexattr_init(&attr);
-+    pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
-+    pthread_mutex_init(&_mutex, &attr);
-   }
-   else
-   {
--- 
-2.10.2
-
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch b/recipes-core/dbus/libdbus-c++-0.9.0/0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch
deleted file mode 100644 (file)
index 65cd939..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-From c673a76857cbe0ca82fa11aea9b70f94c3e5b041 Mon Sep 17 00:00:00 2001
-From: Peter Williams <peter@newton.cx>
-Date: Sat, 19 Dec 2015 21:08:46 -0500
-Subject: [PATCH] tools/generate_proxy.cpp: avoid possibly undefined 'uint'
- type
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
----
-Upstream-Status: Backport [https://github.com/andreas-volz/dbus-cplusplus/commit/43f119a2b3fe951c0f1d88cc61170d4c81a88880]
-Signed-off-by: André Draszik <adraszik@tycoint.com>
- tools/generate_proxy.cpp | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tools/generate_proxy.cpp b/tools/generate_proxy.cpp
-index bf1094a..ebb75fa 100644
---- a/tools/generate_proxy.cpp
-+++ b/tools/generate_proxy.cpp
-@@ -352,7 +352,7 @@ void generate_proxy(Xml::Document &doc, const char *filename)
-         if (!arg_name.length())
-         {
-           arg_name = "argin";
--          arg_name += toString <uint> (i);
-+          arg_name += toString <unsigned int> (i);
-         }
-         // generate extra code to wrap object
-@@ -445,7 +445,7 @@ void generate_proxy(Xml::Document &doc, const char *filename)
-           if (!arg_name.length())
-           {
--            arg_name = "argout" + toString <uint> (i);
-+            arg_name = "argout" + toString <unsigned int> (i);
-           }
-           if (arg_object.length())
-@@ -569,7 +569,7 @@ void generate_proxy(Xml::Document &doc, const char *filename)
-         // use a default if no arg name given
-         if (!arg_name.length())
-         {
--          arg_name = "arg" + toString <uint> (i);
-+          arg_name = "arg" + toString <unsigned int> (i);
-         }
-         body << arg_name << ";" << endl;
-@@ -605,7 +605,7 @@ void generate_proxy(Xml::Document &doc, const char *filename)
-         if (!arg_name.length())
-         {
--          arg_name = "arg" + toString <uint> (j);
-+          arg_name = "arg" + toString <unsigned int> (j);
-         }
-         if (arg_object.length())
--- 
-2.10.2
-
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch b/recipes-core/dbus/libdbus-c++-0.9.0/0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch
deleted file mode 100644 (file)
index f69cefd..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 465d98dbcdcb72375c198010a50b80b953e7d5a6 Mon Sep 17 00:00:00 2001
-From: Yuri <yuri@tsoft.com>
-Date: Sat, 28 May 2016 13:20:10 -0700
-Subject: [PATCH] Fixed undefined ssize_t for clang-3.8.0 on FreeBSD.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
----
-Upstream-Status: Backport [https://github.com/andreas-volz/dbus-cplusplus/commit/463f5a4400d494b831c3b3348c0a21f0faf14f39]
-Signed-off-by: André Draszik <adraszik@tycoint.com>
- include/dbus-c++/pipe.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/include/dbus-c++/pipe.h b/include/dbus-c++/pipe.h
-index 999f042..682646c 100644
---- a/include/dbus-c++/pipe.h
-+++ b/include/dbus-c++/pipe.h
-@@ -30,6 +30,8 @@
- /* STD */
- #include <cstdlib>
-+#include <sys/types.h>
-+
- namespace DBus
- {
--- 
-2.10.2
-
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch b/recipes-core/dbus/libdbus-c++-0.9.0/0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch
deleted file mode 100644 (file)
index 0c2c487..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-From 12de53b0f24c478ea4ff6b4e2c55366dbd2f02b1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <git@andred.net>
-Date: Fri, 25 Nov 2016 09:33:20 +0000
-Subject: [PATCH] use POSIX poll.h instead of sys/poll.h
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-POSIX specifies that <poll.h> is the correct header to
-include for poll()
-  http://pubs.opengroup.org/onlinepubs/009695399/functions/poll.html
-whereas <sys/poll.h> is only needed for ancient glibc (<2.3),
-so let's follow POSIX instead.
-
-As a side-effect, this silences compilation warnings when
-compiling against the musl C-library such as:
-
-| In file included from ../../libdbus-c++-0.9.0/src/eventloop.cpp:31:0:
-| <sysroot>/usr/include/sys/poll.h:1:2: warning: #warning redirecting incorrect #include <sys/poll.h> to <poll.h> [-Wcpp]
-|  #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
-|   ^~~~~~~
-| In file included from ../../libdbus-c++-0.9.0/src/eventloop-integration.cpp:39:0:
-| <sysroot>/usr/include/sys/poll.h:1:2: warning: #warning redirecting incorrect #include <sys/poll.h> to <poll.h> [-Wcpp]
-|  #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
-|   ^~~~~~~
-
-Signed-off-by: André Draszik <git@andred.net>
----
-Upstream-Status: Submitted [https://github.com/andreas-volz/dbus-cplusplus/pull/3]
-Signed-off-by: André Draszik <adraszik@tycoint.com>
- src/eventloop-integration.cpp | 2 +-
- src/eventloop.cpp             | 2 +-
- src/pipe.cpp                  | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/eventloop-integration.cpp b/src/eventloop-integration.cpp
-index 5776971..271b503 100644
---- a/src/eventloop-integration.cpp
-+++ b/src/eventloop-integration.cpp
-@@ -36,7 +36,7 @@
- /* STD */
- #include <string.h>
- #include <cassert>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <fcntl.h>
- #include <unistd.h>
-diff --git a/src/eventloop.cpp b/src/eventloop.cpp
-index f622812..7790e1e 100644
---- a/src/eventloop.cpp
-+++ b/src/eventloop.cpp
-@@ -28,7 +28,7 @@
- #include <dbus-c++/eventloop.h>
- #include <dbus-c++/debug.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <sys/time.h>
- #include <dbus/dbus.h>
-diff --git a/src/pipe.cpp b/src/pipe.cpp
-index 01211b3..45c2ba6 100644
---- a/src/pipe.cpp
-+++ b/src/pipe.cpp
-@@ -32,7 +32,7 @@
- /* STD */
- #include <unistd.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <fcntl.h>
- #include <errno.h>
- #include <cassert>
--- 
-2.10.2
-
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch b/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch
deleted file mode 100644 (file)
index 903a720..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-
-sniped from ChromiumOS
-
-https://bugs.gentoo.org/424707
-
-From 154f7861d19a2bd5c79c488f9989610971db451b Mon Sep 17 00:00:00 2001
-From: Han Shen <shenhan@google.com>
-Date: Thu, 31 May 2012 16:49:35 -0700
-Subject: [PATCH] Fixed dbus-c++ gcc 4.7 building problem.
-
-Just add "unistd.h" inclusion to eventloop-integration.h.
-
-BUG=None
-TEST=Manually built using gcc 4.7.
-
-Change-Id: I87bd1f90db6a4c974a5ed8134044e8be2034aff2
-Reviewed-on: https://gerrit.chromium.org/gerrit/24260
-Tested-by: Han Shen <shenhan@google.com>
-Reviewed-by: Yunlian Jiang <yunlian@chromium.org>
-Commit-Ready: Han Shen <shenhan@chromium.org>
-Upstream-Status: Inappropriate [ not author, no upstream ]
-Signed-off-by: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
----
- include/dbus-c++/eventloop-integration.h |    1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/dbus-c++/eventloop-integration.h b/include/dbus-c++/eventloop-integration.h
-index 5108340..1b56ab5 100644
---- a/include/dbus-c++/eventloop-integration.h
-+++ b/include/dbus-c++/eventloop-integration.h
-@@ -27,6 +27,7 @@
- #include <cstring>
- #include <errno.h>
-+#include <unistd.h>
- #include "api.h"
- #include "dispatcher.h"
- #include "util.h"
--- 
-1.7.9.7
diff --git a/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch b/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch
deleted file mode 100644 (file)
index fa29d3c..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
-Date: Fri, 18 Nov 2016 10:23:07 +0100
-Subject: Build libdbus-c++ tools for target platform rather than enforced for
-host platform.
-
-Upstream-Status: Inappropriate [no upstream]
-Signed-off-by: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
----
-
-diff -Naur libdbus-c++-0.9.0.ori/configure.ac libdbus-c++-0.9.0/configure.ac
---- libdbus-c++-0.9.0.ori/configure.ac 2016-11-15 14:25:36.085882774 +0100
-+++ libdbus-c++-0.9.0/configure.ac     2016-11-15 14:27:08.814568717 +0100
-@@ -64,9 +64,6 @@
- AC_PROG_CC
- AC_PROG_CXX
--CXX_FOR_BUILD=${CXX_FOR_BUILD-${CXX}}
--AC_SUBST(CXX_FOR_BUILD)
--
- AM_PROG_LIBTOOL
- PKG_PROG_PKG_CONFIG
-diff -Naur libdbus-c++-0.9.0.ori/tools/Makefile.am libdbus-c++-0.9.0/tools/Makefile.am
---- libdbus-c++-0.9.0.ori/tools/Makefile.am    2016-11-15 14:25:36.089882803 +0100
-+++ libdbus-c++-0.9.0/tools/Makefile.am        2016-11-15 14:26:19.454203583 +0100
-@@ -1,7 +1,5 @@
- # hacky, but ...
--CXX = $(CXX_FOR_BUILD)
--
- AM_CPPFLAGS = \
-       $(dbus_CFLAGS) \
-       $(xml_CFLAGS) \
diff --git a/recipes-core/dbus/libdbus-c++_0.9.0.bb b/recipes-core/dbus/libdbus-c++_0.9.0.bb
deleted file mode 100644 (file)
index 9b053fe..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "DBus-C++ Library"
-DESCRIPTION = "DBus-c++ attempts to provide a C++ API for D-BUS. The library has a glib and an Ecore mainloop integration. It also offers an optional own main loop."
-HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
-SECTION = "base"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS = "dbus expat glib-2.0 libpcre"
-
-SRC_URI = "\
-    ${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \
-    file://fix-missing-unistd.h-include.patch \
-    file://remove-CXX_FOR_BUILD-stuff.patch \
-    file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \
-    file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \
-    file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \
-    file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
-"
-SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
-SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
-
-PACKAGE_BEFORE_PN = "${PN}-tools"
-
-FILES_${PN}-tools = "${bindir}"
-
-BBCLASSEXTEND = "native"
diff --git a/recipes-core/dbus/libdbus-c++_0.9.0.bbappend b/recipes-core/dbus/libdbus-c++_0.9.0.bbappend
new file mode 100644 (file)
index 0000000..ea83587
--- /dev/null
@@ -0,0 +1 @@
+PNBLACKLIST[libdbus-c++] = ""
index 9de5018..251bc58 100644 (file)
@@ -1,46 +1,55 @@
-diff -Naur old/ivi-input-api/test/CMakeLists.txt new/ivi-input-api/test/CMakeLists.txt
---- old/ivi-input-api/test/CMakeLists.txt      2015-10-20 00:25:36.000000000 +1000
-+++ new/ivi-input-api/test/CMakeLists.txt      2015-10-20 17:57:45.000000000 +1000
-@@ -66,14 +66,15 @@
+From fbe0d0fd35ff79561dc2da853f1b0903bfde428d Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Thu, 1 Jun 2017 07:45:20 +0000
+Subject: [PATCH] test patch
+
+---
+ ivi-input-api/test/CMakeLists.txt           | 9 +++++----
+ ivi-layermanagement-api/test/CMakeLists.txt | 7 ++++---
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/ivi-input-api/test/CMakeLists.txt b/ivi-input-api/test/CMakeLists.txt
+index db05d0f..db3b745 100644
+--- a/ivi-input-api/test/CMakeLists.txt
++++ b/ivi-input-api/test/CMakeLists.txt
+@@ -65,12 +65,13 @@ IF(BUILD_ILM_API_TESTS)
      ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
  
-     IF(INSTALL_ILM_API_TESTS)
--        INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+        INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+        INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-input-api)
-     ENDIF()
+-    INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++    INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++    INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
  
      # use CTest
      ENABLE_TESTING()
 -    ADD_TEST(ilmCommon  ${PROJECT_NAME})
--    ADD_TEST(ilmClient  ${PROJECT_NAME})
 -    ADD_TEST(ilmControl ${PROJECT_NAME})
 -    ADD_TEST(ilmInput ${PROJECT_NAME})
-+    ADD_TEST(ilmCommon  ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+    ADD_TEST(ilmClient  ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+    ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+    ADD_TEST(ilmInput ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++    ADD_TEST(ilmCommon  {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++    ADD_TEST(ilmControl {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++    ADD_TEST(ilmInput   {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
  
  ENDIF()
-diff -Naur old/ivi-layermanagement-api/test/CMakeLists.txt new/ivi-layermanagement-api/test/CMakeLists.txt
---- old/ivi-layermanagement-api/test/CMakeLists.txt    2015-10-20 00:25:36.000000000 +1000
-+++ new/ivi-layermanagement-api/test/CMakeLists.txt    2015-10-20 17:57:24.000000000 +1000
-@@ -64,13 +64,14 @@
+diff --git a/ivi-layermanagement-api/test/CMakeLists.txt b/ivi-layermanagement-api/test/CMakeLists.txt
+index fe9a0a4..090d734 100644
+--- a/ivi-layermanagement-api/test/CMakeLists.txt
++++ b/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -63,11 +63,12 @@ IF(BUILD_ILM_API_TESTS)
      ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
  
-     IF(INSTALL_ILM_API_TESTS)
--        INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+        INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+        INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
-     ENDIF()
+-    INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++    INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++    INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
  
      # use CTest
      ENABLE_TESTING()
 -    ADD_TEST(ilmCommon  ${PROJECT_NAME})
--    ADD_TEST(ilmClient  ${PROJECT_NAME})
 -    ADD_TEST(ilmControl ${PROJECT_NAME})
 +    ADD_TEST(ilmCommon  ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+    ADD_TEST(ilmClient  ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
 +    ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
  
  ENDIF() 
+-- 
+2.7.4
+
index 5a26c9a..9c29dee 100644 (file)
@@ -8,10 +8,9 @@ DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
     -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
     "
 
-PACKAGECONFIG ??= "ilm_input test"
+PACKAGECONFIG ??= "test"
 PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
 
-
 SRC_URI_append = "\
     file://cmake-find-gtest.patch \
     file://test-path.patch \
index 9182491..dd397fc 100644 (file)
@@ -29,6 +29,16 @@ TTF_FONTS = " \
     ttf-dejavu-serif \
     "
 
+# Add webkit as workaround as webengine is broken right now
+EXTRA_APPS_append = " qtwebkit qtwebkit-examples-examples"
+#EXTRA_APPS_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
+#IMAGE_INSTALL_append = " qtwebengine-examples"
+
+# add support for websocket in Qt and QML
+EXTRA_APPS_append = " qtwebsockets qtwebsockets-qmlplugins"
+PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
+
+
 RDEPENDS_${PN} += " \
     linux-firmware-ath9k \
     can-utils \
@@ -36,4 +46,5 @@ RDEPENDS_${PN} += " \
     python-curses \
     dhcp-client \
     ${TTF_FONTS} \
+    ${EXTRA_APPS} \
     "
index ab6fe9a..af2722d 100644 (file)
@@ -13,3 +13,6 @@ EXTRA_OECONF_append = ""
 
 # '-qpa wayland-egl' set wayland-egl as default of platform plagins
 PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"
+
+# Temporarily fix bug due to binutils 2.28
+QT_CONFIG_FLAGS_append = " -no-use-gold-linker"