9b053fed841bddd6f21d35b4a6f5e1502dc4746a
[AGL/meta-agl-demo.git] / recipes-core / dbus / libdbus-c++_0.9.0.bb
1 SUMMARY = "DBus-C++ Library"
2 DESCRIPTION = "DBus-c++ attempts to provide a C++ API for D-BUS. The library has a glib and an Ecore mainloop integration. It also offers an optional own main loop."
3 HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
4 SECTION = "base"
5 LICENSE = "LGPLv2.1"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
7 DEPENDS = "dbus expat glib-2.0 libpcre"
8
9 SRC_URI = "\
10     ${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \
11     file://fix-missing-unistd.h-include.patch \
12     file://remove-CXX_FOR_BUILD-stuff.patch \
13     file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \
14     file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \
15     file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \
16     file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
17 "
18 SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
19 SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
20
21 inherit autotools pkgconfig
22
23 EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
24
25 PACKAGE_BEFORE_PN = "${PN}-tools"
26
27 FILES_${PN}-tools = "${bindir}"
28
29 BBCLASSEXTEND = "native"