Fix for user and group of /home/agl-driver 87/28587/1
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Mar 2023 20:17:45 +0000 (22:17 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Mar 2023 20:17:45 +0000 (22:17 +0200)
The private nssdb introduced wrong access rights for /home/agl-driver through the package.

Fix it till we have it reworked.

Bug-AGL: SPEC-4599
Change-Id: I665b51f8473f64785c64c55359b5e0e702050e9a
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-connectivity/kuksa-val/kuksa-val_git.bb
recipes-core/nss/nss-agl-driver-db_git.bb

index 2c1966f..48cda10 100644 (file)
@@ -79,7 +79,7 @@ do_install:append() {
 
 pkg_postinst_ontarget:${PN}-client-certificates () {
     certutil -A -d /home/agl-driver/.pki/nssdb -n "KuksaRootCA" -t "pC,," -i ${sysconfdir}/kuksa-val/CA.pem
-    chown agl-driver:agl-driver -R /home/agl-driver/.pki/
+    chown agl-driver:agl-driver -R /home/agl-driver/
 }
 
 # Put client certificates into their own package so we can avoid
index ba203d4..3d8aa5f 100644 (file)
@@ -12,10 +12,11 @@ do_compile[noexec] = "1"
 do_install() {
     mkdir -p ${D}/home/agl-driver/.pki/nssdb
     certutil -N -d ${D}/home/agl-driver/.pki/nssdb --empty-password
+    chown -R 1001:1001 ${D}/home/agl-driver
 }
 
 pkg_postinst_ontarget:${PN} () {
-    chown agl-driver:agl-driver -R /home/agl-driver/.pki/
+    chown agl-driver:agl-driver -R /home/agl-driver/
 }
 
 FILES:${PN} += "/home/agl-driver/.pki/*"