ba203d4e65cdca879a75ebb3168c0c22d065998c
[AGL/meta-agl-demo.git] / recipes-core / nss / nss-agl-driver-db_git.bb
1 SUMMARY = "Custom nss db hosting the kuksa certificates"
2 DESCRIPTION = "Custom nss db hosting the kuksa certificates for chromium"
3 AUTHOR = "Jan-Simon Moeller <jsmoeller@linuxfoundation.org>"
4 HOMEPAGE = "https://git.automotivelinux.org"
5 LICENSE = "MIT"
6 DEPENDS = " agl-session nss-native"
7 PV = "0.1"
8
9 do_configure[noexec] = "1"
10 do_compile[noexec] = "1"
11
12 do_install() {
13     mkdir -p ${D}/home/agl-driver/.pki/nssdb
14     certutil -N -d ${D}/home/agl-driver/.pki/nssdb --empty-password
15 }
16
17 pkg_postinst_ontarget:${PN} () {
18     chown agl-driver:agl-driver -R /home/agl-driver/.pki/
19 }
20
21 FILES:${PN} += "/home/agl-driver/.pki/*"