Allow SRCREV handling through poky-agl.conf 87/11687/1 4.99.2 eel/4.99.2 eel_4.99.2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sun, 5 Nov 2017 11:56:07 +0000 (12:56 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sun, 5 Nov 2017 11:56:10 +0000 (12:56 +0100)
This change simplifies the SRCREV handling by using
- AGL_APP_REVISION and AGL_DEFAULT_REVISION
in recipes.
Also the AGL_BRANCH can be used to switch to release branches.

Finally git checkouts should use https by default.

Bug-AGL: SPEC-864

Change-Id: I2fdacda8fa7373f309a47db72ad40106ade53434
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
31 files changed:
recipes-demo-hmi/agl-service-bluetooth/agl-service-bluetooth_git.bb
recipes-demo-hmi/agl-service-geoclue/agl-service-geoclue_git.bb
recipes-demo-hmi/agl-service-geofence/agl-service-geofence_git.bb
recipes-demo-hmi/agl-service-gps/agl-service-gps_git.bb
recipes-demo-hmi/agl-service-mediaplayer/agl-service-mediaplayer_git.bb
recipes-demo-hmi/agl-service-mediascanner/agl-service-mediascanner_git.bb
recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
recipes-demo-hmi/agl-service-steering-wheel/agl-service-steering-wheel_0.1.bb
recipes-demo-hmi/agl-service-wifi/agl-service-wifi_git.bb
recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb
recipes-demo-hmi/can-lin/can-lin_0.2.bb
recipes-demo-hmi/controls/controls_git.bb
recipes-demo-hmi/dashboard/dashboard_git.bb
recipes-demo-hmi/homescreen/homescreen_git.bb
recipes-demo-hmi/homescreenappframeworkbinderagl/homescreenappframeworkbinderagl_git.bb
recipes-demo-hmi/hvac/hvac_git.bb
recipes-demo-hmi/inputeventmanager/inputeventmanager_git.bb
recipes-demo-hmi/libhomescreen/libhomescreen-2017.inc
recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
recipes-demo-hmi/mixer/mixer_git.bb
recipes-demo-hmi/phone/phone_git.bb
recipes-demo-hmi/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
recipes-demo-hmi/radio/radio_git.bb
recipes-demo-hmi/settings/settings_git.bb
recipes-demo-hmi/unicens/unicens_0.1.bb
recipes-demo-hmi/vod-server/vod-server_0.1.bb
recipes-demo-hmi/windowmanager/windowmanager_git.bb
recipes-kernel/mocca-usb/mocca-usb.bb
recipes-kernel/most/most.bb

index 1f483e2..0ecc10e 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-bluetooth;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-bluetooth;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 1da7448..1f93877 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-geoclue;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-geoclue;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 2a7736c..a6b57ae 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-geofence;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-geofence;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index fe6a772..501597b 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-gps;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-gps;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 8e69da4..c5cf71c 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediaplayer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index fa3be79..3a6d218 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediascanner;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediascanner;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index bab9f13..0e913af 100644 (file)
@@ -8,8 +8,8 @@ LICENSE     = "Apache-2.0 & GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 52df7a5..65328ff 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 SECTION = "apps"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-steering-wheel;protocol=http;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-steering-wheel;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "44e29d0b7b0382214dfae5b82c1c038d6bf7877f"
 
 PN          = "agl-service-steering-wheel"
index 2e322a4..2b680f4 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-wifi;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-wifi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 40eadd0..955535b 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/als-meter-demo;protocol=https;branch=master"
-SRCREV = "aa15796ee333339673a8b4ac5468050a9a5b7f93"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/als-meter-demo;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 PV = "0.1+git${SRCPV}"
 S  = "${WORKDIR}/git"
index efbda3c..287fe4e 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "CAN-LIN Application"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI += "file://hvac-demo.service"
 
 S = "${WORKDIR}/git"
index 7be699f..1b19759 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/controls;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/controls;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 2e025eb..5d02ea2 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 7746e5e..e7d07cf 100644 (file)
@@ -13,12 +13,12 @@ RDEPENDS_${PN} = " \
        windowmanager"
 
 LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=http \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=https;branch=${AGL_BRANCH} \
            file://dbus-homescreen.conf.in"
+SRCREV  = "${AGL_APP_REVISION}"
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
index d1a1904..5a5e967 100644 (file)
@@ -9,12 +9,12 @@ inherit qmake5 systemd
 DEPENDS = " qtbase "
 
 LIC_FILES_CHKSUM = "file://homescreenappframeworkbinderagl/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/homescreenappframeworkbinderagl.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/homescreenappframeworkbinderagl.git;protocol=http"
-
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 do_install() {
index 425052c..beaaafa 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index fff0a2f..744f80c 100644 (file)
@@ -9,12 +9,12 @@ inherit qmake5 systemd
 DEPENDS = " qtbase "
 
 LIC_FILES_CHKSUM = "file://inputeventmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/inputeventmanager.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_DEFAULT_REVISION}"
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/inputeventmanager.git;protocol=http"
-
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 do_install() {
index 75ac0e5..f8432bd 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS = "af-binder json-c"
 
 inherit cmake
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=http;branch=master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "390902a6b002c6af183c939749fdebfcc4b3e839"
 S = "${WORKDIR}/git"
 
index 57449b7..4ec2860 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS += " glib-2.0 "
 
 inherit qmake5 pkgconfig
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=http \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
            file://homescreen.pc.in"
 SRCREV  = "f5c14333d2170ae9babed53ea530828569a830ff"
 S       = "${WORKDIR}/git/"
index d7c4c85..8a7fd62 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index f0ca5d9..638dae5 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index e67c0a3..191f3e5 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 7fa8a57..a0af21a 100644 (file)
@@ -7,8 +7,8 @@ DEPENDS = "qtquickcontrols2"
 
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=http"
-SRCREV = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git/"
 
index 6626811..38f3f9f 100644 (file)
@@ -7,8 +7,8 @@ DEPENDS = "qtquickcontrols2"
 
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http"
-SRCREV = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git/"
 
index 584cb71..5b599de 100644 (file)
@@ -7,12 +7,12 @@ LICENSE     = "Apache-2.0 & GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=http \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
            file://presets-ALS.conf \
            file://presets-CES.conf \
            file://presets-FOSDEM.conf \
 "
-SRCREV  = "${AUTOREV}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index a1d26d7..28eee06 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
index 0fc0afc..7b854ea 100644 (file)
@@ -8,7 +8,7 @@ PV = "0.1"
 
 DEPENDS += "libxml2"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
 SRC_URI += "file://0001-Support-booting-by-systemd.patch \
             file://most-network-startup.service \
@@ -16,7 +16,7 @@ SRC_URI += "file://0001-Support-booting-by-systemd.patch \
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_DEFAULT_REVISION}"
 
 do_install() {
     install -m 0755 -d ${D}/usr/AGL/most
index 3d724bd..73b7fb7 100644 (file)
@@ -6,13 +6,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
 
 PV = "0.1"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
             file://vod-demo.service"
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_DEFAULT_REVISION}"
 
 do_install() {
         install -m 0755 -d ${D}${bindir}
index f6119aa..676c625 100644 (file)
@@ -12,11 +12,11 @@ DEPENDS = " qtbase "
 DEPENDS += " wayland-ivi-extension "
 
 LIC_FILES_CHKSUM = "file://windowmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
+SRCREV  = "${AGL_DEFAULT_REVISION}"
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/windowmanager.git;protocol=http"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/windowmanager.git;protocol=https;branch=${AGL_BRANCH}"
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
index 246f25b..cf4e585 100644 (file)
@@ -6,7 +6,7 @@ inherit module
 
 PV = "0.1"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=${AGL_BRANCH}"
 S = "${WORKDIR}/git/Usb-Driver"
 SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
 
index 512610a..dd676c7 100644 (file)
@@ -6,12 +6,12 @@ inherit module
 
 PV = "0.1"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
                           file://0001-aim-sound-3.10.31-ltsi-backport.patch \
                         "
 S = "${WORKDIR}/git/driver"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_DEFAULT_REVISION}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.