Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd pkgconfig
9 DEPENDS = " qtbase qtdeclarative qtquickcontrols2 pulseaudio"
10 RDEPENDS_${PN} = " \
11         homescreenappframeworkbinderagl \
12         inputeventmanager \
13         windowmanager"
14
15 LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=https;branch=${AGL_BRANCH} \
18            file://dbus-homescreen.conf.in"
19 SRCREV  = "${AGL_APP_REVISION}"
20 # PV needs to be modified with SRCPV to work AUTOREV correctly
21 PV = "0.0+git${SRCPV}"
22
23 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
24
25 do_install() {
26     install -d ${D}/usr/AGL/${PN}
27     install -m 0755 ${B}/homescreen/HomeScreen ${D}/usr/AGL/${PN}/
28     install -m 0755 ${B}/sampleapptimedate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
29
30 # claneys: add dbus policy to make wifi/bluetooth status icon working as quick 
31 # workaround. (jira.automotivelinux.org : SPEC-377)
32     install -d ${D}/etc/dbus-1/session.d
33     install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
34
35     install -d ${D}${systemd_user_unitdir}
36     install -m 0644 ${S}/homescreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
37
38     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
39     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
40 }
41
42 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
43 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
44