html5-dashboard: recover HTML5 dashboard demo application. 74/27574/3
authorJose Dapena Paz <jdapena@igalia.com>
Mon, 23 May 2022 11:20:02 +0000 (13:20 +0200)
committerJose Dapena Paz <jdapena@igalia.com>
Fri, 10 Jun 2022 18:33:21 +0000 (20:33 +0200)
Add updated html5-dashboard:
* Fixes build with new application framework  providing lowcan mock.
* Updates NPM dependencies.
* Updates recipe for kirkstone.

Bug-AGL: SPEC-4248
Change-Id: I5606e194d3009b96050023aae4de2b4736c126aa
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
recipes-demo/html5-dashboard/files/webapps-dashboard.desktop [new file with mode: 0644]
recipes-demo/html5-dashboard/html5-dashboard_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop b/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop
new file mode 100644 (file)
index 0000000..49da964
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Dashboard
+Comment=Dashboard
+GenericName=Dashboard
+Exec=/usr/bin/WebAppMgr --appid=webapps-dashboard --app-install-dir=/usr/lib/wam_apps/html5-dashboard/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-dashboard/html5-dashboard_git.bb b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
new file mode 100644 (file)
index 0000000..b511807
--- /dev/null
@@ -0,0 +1,42 @@
+SUMMARY     = "AGL HTML5 dashboard Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
+
+SRC_URI = " \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=master \
+  file://webapps-dashboard.desktop \
+"
+SRCREV = "4680db99615757df9d9cc561c9a9fc5b9b1c108a"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+  cd ${S}
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-dashboard.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"
index b00883b..056faa0 100644 (file)
@@ -30,7 +30,7 @@ RDEPENDS:${PN}:append = " \
 
 # TODO(jdapena): replace this with HTML5 apps.
 AGL_APPS = " \
-    dashboard \
+    html5-dashboard \
     html5-launcher \
     html5-homescreen \
     html5-hvac \